0

I am trying to root an Acer Iconia Tab A200 tablet using a script. I have adb working and fastboot works too, however, command fastboot devices returns a list of question marks. Eg:

???????????? fastboot

Image ilustrates the steps followed and the result:fastboot

I execute command fastboot devices in the bootloader which is already unlocked. Using Ubuntu 14.04. udev settings are already set (the file with vendors IDs).

What can I do to get the correct result? How can I make fastboot work well?

Thanks in advance!

  • Android devices often have a different vendor/product ID in fastboot mode to when they're booted normally. Have you made sure to enter both in the udev config? – Dan Hulme Jun 1 '14 at 18:57
  • @DanHulme ok, I found something about adding a particular ID for the device and added it to the udev file, however, I still get the same results. – Francisco Jun 1 '14 at 21:06
  • You don't need to "find something" about it: the ID is different for each device. You can find it by running lsusb. – Dan Hulme Jun 1 '14 at 21:52
  • @DanHulme dude, that is exactly what I meant with something. Anyway, I added it to the file using the udev notation but got the same result. This is the text I found and the id result of the command lsusb: SUBSYSTEM=="usb", ATTRS{idVendor}=="0502", ATTRS{idProduct}=="3201", MODE="0666", GROUP="plugdev", OWNER="ln" – Francisco Jun 2 '14 at 2:00
0

It can be a cable fault. Change the cable. In my Redmi 3 on a cable from old Xperia P i've had question marks, replaced the cable to a newer cable from Redmi Note 2 and voila - the correct number displays instead of the question marks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.