0

I recently re-activated an old phone with my carrier. (To give you an idea how old, it is running Android 2.3.3, whereas the latest available for this phone is 2.3.4) It doesn't have the latest OTA update, but when I try to check for new updates ("Settings":"About Phone":"System Updates") I get the message

"Checking for available update. Please wait..."

and a spinner which just spins and spins. It never progresses past this point. If I back out and try to check again it usually doesn't even get to the spinner, sometimes I have to tap it many times before the spinner will even come up - some taps appear to do nothing and some appear to flash the "Checking..." for a split second.

The phone has been rooted, but as far as I know that shouldn't affect an OTA update (although I understand the update will remove the rooting). Is it possible that OTA updates are discontinued after a while? This update is 2-3 years old. Is there anything else I can do to troubleshoot what the problem is?

(I realize I could try wiping the device, in case there is something on the device that is preventing the update, but my concern is that if OTAs do expire then I would be stuck with an even older version on the device.)

Update: It looks like the BlurUpdater_VZW.apk (and odex) were missing. However, the only copy I found appears to be from the 4.5.629 update and not the 4.5.608 that is on the phone, and it exhibits the same behavior. If I run the 4.5.629 version on a device with 4.5.629, I get a message that no updates are available, so maybe this means that if I can find a 4.5.608 version of the BlurUpdater files, that will work?

  • As far as I know the OTA updates don't expire and should still be available to you. (sorry I couldn't be of more help) – user61232 Jun 2 '14 at 18:32
  • @DanielStewart ok, thanks. i might just have to take a chance on wiping and hoping i can re-update. – Michael Jun 2 '14 at 18:44
  • If it comes to that you could always just install it manually given you can find the update online (or even a custom ROM) – user61232 Jun 2 '14 at 19:01
  • Rooting a phone usually prevents OTA updates from installing, because the system partition has been altered. Sometimes the OTA update simply unroots the device, but it's different for different models. – Dan Hulme Jun 2 '14 at 22:57
0

Here is how I solved the problem. It turns out that the BlurUpdater files are specific to the version you are running, and I didn't have the correct version. It was a bit of work to locate the correct version.

First, I downloaded the SBF file for 4.5.608. I then used the sbf_flash utility using the -x option to extract the images in the SBF. I then used the file -sL XX.img command to determine that the larger images were ext3 formatted filesystems. Then I used mount -t ext3 -o loop XX.img tmp/ to mount each filesystem until I found the one containing the BlurUpdater_VZW.apk and BlurUpdater_VZW.odex file. Then I installed both of these files in /system/app (as root). After restarting my device and running the check for updates I was informed that an update was available, which I was then able to start installing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.