6

I have recently bought a Samsung Galaxy S4, Android version 4.4.2, and for some reason I only receive my WhatsApp messages when I open the app. This only happens when I am on 3G. When connected to a WiFi network, there is no delay at all.

I have uninstalled and re-installed, I have checked the restricted data setting (it is not ticked).

What did I miss?

  • By "restricted data setting" do you mean "Restrict background data"? – onik Jun 4 '14 at 9:01
  • 1
    Also uncheck "Restrict background data" on Google Play services – HairyFotr Apr 20 '17 at 13:37
5

Samsung phones have an option to sync data in the background, disabling it, saves data, as updates are only checked for when an app is open (email/im/whatsapp etc). You need to enable that (see green icon in image below) to let your apps periodically check for data.

Screenshot
Screenshot (click for larger variant)

| improve this answer | |
  • That's not specific to Samsung devices (though maybe the way they're placing it in the quick access bar is). All Android devices have that. But you're 100% correct in identifying the most likely culprit :) – Izzy Jun 4 '14 at 10:52
  • 1
    your right, of course, android has this built in since its early days, but its not so readily accessible on other manufacturers phones - and I've seen this culprit for this issue on a number of family/friends samsung phones. They do not understand it and turn it off, leading to issues. – Husman Jun 4 '14 at 11:07
4

Could this also be in your "Smart Manager". When you click on "Battery", it says "Optimising". When your apps are selected, it will only updates when you actually opens the app. And it can also be your "power saving mode" problem in smart manager. Once you click on power saving it shows you restrict all background data, this should be disabled.enter image description here

| improve this answer | |
  • The problem and this solution are not restricted to Samsung. Asus has a power saver with 4 levels, two of which turn off networks when asleep. – cipricus Nov 21 '17 at 10:20

Not the answer you're looking for? Browse other questions tagged or ask your own question.