10

I never turn my WiFi on because I have an unlimited data plan. I recently noticed that it is autonomously enabled randomly.

How can I find the culprit that keeps turning my WiFi on? Is there a way I can catch the application that launched the WiFi enable Intent?

I have been going on a blind search thus far and I still notice my WiFi turning on. Thanks in advance! I have a Nexus 4 running Android 4.4

  • 1
    In my case, it turned out to be the Anti-theft feature of Avast because I recently changed my sim card. Hopefully this saves someone the pain I went through... – Freedom_Ben Oct 22 '14 at 22:23
  • I had the same thing happening on my Huawei phone. Turns out it was the Wi-Fi+ feature. Settings -> Wi-Fi -> Wi-Fi+ -> Off. – Antoni4 Nov 18 '17 at 12:12
5

KitKat has a feature where, when Wi-Fi is turned off, it periodically scans for networks to allow Wi-Fi-based location detection to work. To turn this off:-

  1. Go to the Wi-Fi settings
  2. On the overflow menu (the three dots) select Advanced
  3. Uncheck Scanning always available

Even when an app turns on Wi-Fi fully, this isn't done with an intent; rather, it's done by calling the method WifiManager.setWifiEnabled. Only apps with the permission "connect and disconnect from Wi-Fi" can do this.

  • 1
    Thanks for the response! I have previously unchecked this option, but the issue remains. – Miron V Jun 4 '14 at 22:35
5

If it's not that KitKat feature Dan mentioned, and the intervals are reasonably short (so e.g. it happens at least once while you're sleeping at night):

  • enable USB debugging
  • connect your device to your PC via USB
  • on your PC, run adb logcat | tee wifi.log
  • go to bed
  • next morning, press Ctrl+C
  • check wifi.log to see when it was triggered (and hopefully, by whom)

This should at least help narrowing things down. Even if it doesn't explicitly state "App X triggering WiFi", you can check for patterns, like "evertime WiFi had been turned on, I find event Z of app X mentioned a few lines before". Good indicator it might have to do with X then. So check whether X has some network (or "coarse location") permissions requested (and granted), as if not, it's unlikely to be your candidate. Otherwise, try disabling/freezing/uninstalling it, and see if your issue is gone. If so, you found it – if not, repeat with the next.

  • @Izzy can I simply find the applications with the Wi-Fi change state permission and then simply un-install the app on Android 4.1.2.The same problem only occurs regular time intervals. – user285oo6 Aug 8 '14 at 6:12
  • If you want to use that approach, see my answer here. Combining the two approaches might be a little safer, so you don't uninstall the wrong app ;) – Izzy Aug 8 '14 at 8:38
2

I had the same issue with my device (Note 3). T-Mobile doesn't seem to have a "Connection Optimizer" feature in its line of phones. In T-mo's case the feature that needs to be disabled is the "Wi-Fi Manager".

To disable this feature you need to do the following:

  • Access your T-Mobile account (for me I just press on the "T-Mobile My Account" App).
  • Press the menu button on your device, then select "Options".
  • Under "Notifications" uncheck the box marked "Display Wi-Fi Manager notifications".
  • Under "Connection Assistant" select "Open Wi-Fi manager".
  • Uncheck the box for "Manage Wi-Fi Connections".

That's it...

I talked to T-mobile tech support about an unrelated issue and offhandedly mentioned this problem. The rep informed me that this was a known issue and stated that this issue was being addressed. In the mean time disabling the "Wi-Fi Manager" is a temporary fix to address this problem. Here is the shorthand way to disable the Wi-Fi manager:

T-Mobile My Account -> Menu -> Options -> "Display Wi-Fi Manager Notifications" (Uncheck) -> "Open Wi-Fi Manager" (under "Connection Assistant") -> (Uncheck) "Manage Wi-Fi Connections".

protected by Community Oct 15 '14 at 16:12

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.