4

Nexus 7 is only charging if it is connected to my mac. It is not being detected in Android Studio nor Android file transfer and there isn't anything popping up or showing a USB symbol on the Nexus. I enabled the "USB debugging" option in the Developer menu. The connection mode was set by default to MTP.

Is there a problem with the cable, port or OS?

  • Can you see the device if you run system_profiler SPUSBDataType in Terminal.app? – onik Jun 5 '14 at 8:55
3

Download the Android File System application.

Install the Android File System app by opening the DMG file, and then dragging the App into your Applications folder.

enter image description here

Once installed, connect your Nexus 7 to your Mac via the USB cable. Open up the Android File System app. It should recognize your tablet and then open up a Finder type window.

enter image description here

You can drag and drop files and media into the window. Additionally, you can create new folders and delete files. Be sure you know what files your deleting as you can break the OS by deleting or altering essential system files.

enter image description here

If you get a “No Device Found” message, be sure your Nexus 7 is in Media device (MTP) transfer mode. You can do this by swiping down to open the notification tray and then tapping on the Connected As… message.

enter image description here

Source

  • I don't understand why this was accepted since the question states the Nexus was not being detected in Android File Transfer. Also, why do you say "Android File System" when all your screenshots show "Android File Transfer"? I'm having the same trouble myself, but the "it should recognize your tablet" step of your instructions is what isn't working. – Wildcard Jul 28 '18 at 1:18
-1

Connect your Nexus 7 to Mac via USB cable. Now go to Settings -> Developer options and turn On the USB debugging.

If you don't see Developer Options under Settings then, go to Settings -> About Tablet and tap on the Build Number multiple times (7 times) to enable the Developer Options.

  • 1
    "I enabled the "USB debugging" option in the Developer menu." -- did you not read the question? – Firelord Aug 24 '15 at 21:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.