5

Is it possible to access other user's emulated sdcard storage on a rooted Nexus 10?

I have 3 users set up. If I log in as the primary user, I would expect to see /storage/emulated/10 (and 11) as well as 0 (and emulated), but I can't (even from a root shell created in ConnectBot).

If it is not possible, how does it work? Is a separate filesystem mounted, or what?

5

Yes, it is possible.

Need a File Manager w/Root

First, you need a file manager that has root access. Personally I use ES File Explorer. Within ES File Explorer, you will need to enable Root access (it's under the Tools part on the left menu).

All users will need to have signed in

All users must have had to signin at least once to create their partitions. Else, you won't see them.

Browse

The exact location is:

/storage/emulated/*  # Android <= 4.4.3 
/mnt/shell/emulated/*         # Android >= 4.4.4 (actually, it may be 4.4.3 too)

Where * is the userid. I am not sure how to get the user ID, but on my tablets with 3 users it shows up as:

/mnt/shell/emulated/0  # owner account
/mnt/shell/emulated/10 # first user I created
/mnt/shell/emulated/11 # second user I created

From what I gather for userids, it goes in order that I created the users. 0 = the first original owner account. Then each account goes up from there (10, 11, 12, etc).

NOTE: If your file manager does NOT have root permissions (meaning the app itself must request root access), then when you enter one of the directories above, they will be blank. This is telling you that your file manager doesn't have root access - you need a file manager that knows how to request Root access.

  • 1
    I use ES File Explorer at present. I can set it to use root (and it asks for access, which I grant). If I have the root setting on, I see only 0 and legacy in /storage/emulated. If I turn OFF root access, I see 10 as well, but it is empty when I view it. Wierd! – Nikki Locke Jun 19 '14 at 9:00
  • Also tried Root Browser, Root File Explorer and Root File Manager. All were the same, except Root File Explorer claimed the phone was not rooted (even though SuperSU thinks it is, and I can access the root folder and do other root things fine). – Nikki Locke Jun 19 '14 at 9:07
  • When i dont have root, i only see 0 and emulated as well. it is only when i am rooted with es file explr root enabled that i see 10 and 11. Try rebooting after giving es file expr root. Also, i am using Android 4.4, though it worked with 4.3. All devices i have are pure google: Nexus 5, 7 and 10. If u are using some other brand (Asus, Samsung, etc), they significantly change Android to suit their needs. They may be fracking with data storage as well. – eduncan911 Jun 19 '14 at 12:01
  • So I upgraded from 4.4.2 -> 4.4.4 on the kid's Nexus 7 FHD and now that path I had previously no longer works! I found a new location using ES File Explorer: /data/user/10 (and /11, etc). I'll update my answer as such. Please remember to mark as ANSWER if it works. :) – eduncan911 Jun 27 '14 at 17:06
  • OK, scratch that.. It's /mnt/shell/emulated/* The one I commented on above is the "app data" location, which is interesting to access to play with. – eduncan911 Jun 27 '14 at 17:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.