6

I have a rather odd thing happening to three apps in the Market, all free. I tried to install Google Maps and Angry Birds Seasons from the market, but the downloads or installations failed and now I can't download them at all. They both show up under My Apps but rather than the Update or Installed statuses that all other apps in My Apps show, these two show FREE. When I try to install them all goes normally until the message displays saying the download is happening, but it doesn't. The downloading icon appears in the status bar for the briefest moment before disappearing again.

I have Aldiko Book Reader installed and indicating that there is an update available. I believe that the download or install failed when I first tried to update and now the behaviour is the same as described above. I try to update but the download doesn't happen.

I have successfully updated and installed other apps in the meantime. For now it's only those three that are stuck. The initial cause of download/install failure may have been lack of memory but there should be enough memory available now.

I am using an HTC Desire running CyanogenMod-7.0.0-RC2 (Gingerbread 2.3.3). Anyone have any ideas on how to resolve this problem? I've looked at the Market in application management but the clear cache and clear data options are not available.

  • 2
    Do you have space for the downloads? – Amanda Mar 21 '11 at 19:40
  • 1
    "I've looked at the Market in application management but the clear cache and clear data options are not available." That's a big problem; you should always be able to clear the Market data (unless you haven't run it since you last cleared data). CM7 has tons of Market issues (google "cm7 market problem" and you'll see); hopefully the next version is better. – Matthew Read Mar 21 '11 at 21:06
3

simple2ext (as described here: http://forum.cyanogenmod.com/topic/20328-solution-to-unable-to-download-big-apps-from-the-market/ ) did the job for me. I am also running CM 7.0.3 and had problems with downloading big apps from market. Sometimes it helped clearing the dalvik cache but not always.

  • Indeed. I too found this a few weeks back but forgot to add some comment here. – Steve Crane May 13 '11 at 6:01
1

I had something similar happen to me months ago, and the only solution I found was to make sure my apps and accounts were synced with Google and doing a factory reset. The thing was I was stock at the time, and I don't know how a factory reset will affect CyanogenMod. I'd jump on their forums and see if anyone else is having a similar issue, and if not you should submit a bug report to them so they can see if it's a bug in their release candidate.

Edit: Since this is a pretty old question and CyanogenMod has been updated I think it would be worth it for you to upgrade to 7.0.3. I haven't had any issues at all with the market now that I've moved to a stable version of CM7 so hopefully your issue has been resolved in the newest stable release.

  • @Steve Crane - Any luck? – newuser Mar 24 '11 at 13:38
  • 1
    Cleared the cache partition and Dalvik cache in recovery and was then able to download updates of some apps that wouldn't download before. Am still unable to download some apps like Google Maps though. – Steve Crane Apr 6 '11 at 10:08
  • Well at least that's something, I suppose. – newuser Apr 6 '11 at 12:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.