6

I have a wireless network set up with a Sweex LC000070 router, WEP encryption and while my HTC Hero can connect to the network, internet doesn't seem to work.

Is there any setting on the router I have to change in order for Android devices to connect?

  • 1
    OK that's strange I updated the firmware of my router and changed from WEP to WPA and now it works... – Ivo Flipse Jul 26 '10 at 5:26
7

Apparently WEP support is thoroughly broked in Android 2.0.1 and above.

http://answerguy.com/2009/12/11/android-2-0-1-update-breaks-droid-wi-fi-wep-encryption/

http://www.droidforums.net/forum/droid-general-discussions/1253-wifi-problem.html (also includes a possible fix for WEP by disabling/enabling the router firewall, though I haven't tried it and ain't gonna...)

http://www.draconos.com/blog/2009/11/19/wifi-on-the-droid

http://www.611connect.com/howto/merben_how-to-enable-wi-fi-on-the-motorola-droid (comments) (also suggests that, if you initially upgrade to WPA to get it working, you can later drop back to WEP and it will continue to work...)

http://www.google.com/support/forum/p/android/thread?tid=130d8d289ec5c8f2&hl=en

That said, WPA is a better choice all around anyway.

  • 2
    Well it's good to know it's due to WEP being crap – Ivo Flipse Jul 27 '10 at 7:26
1

This kind of thing is real problem with non-computer devices. Upgrading to WPA (especially WPA2) will fix the phone but could break other devices (old laptops, TiVo's etc). Another solution is to give up on encryption, especially since WEP isn't really encryption. Almost all routers support MAC filtering, and most support "internet-only" connections, This way you can let any device on your wireless that you know about, and let polite people know they shouldn't connect. Hackers and jerks (not always the same people) can still spoof MAC addresses but that is what "internet-only" is for: you are not exposing your local network over wireless.

Obviously this setup won't work for everyone but it has worked for me in the past, and I might do it again if I get even one more device that can't talk WPA2

0

Have had the same issue on my droid 2.3.6. It used to connect to wifi but could not browse the internet until I disabled:

Parental Control

from my wifi router.

Hope this will help someone.

0

When I first bought my tablet, I, too, faced the same issue. I tweaked the wifi settings a lit bit and it worked. Here is what I did:

Click on advanced checkbox under your wifi network name and click "static ip". Your problem will be solved.

Alternatively, you can try either WPA2-personal encryption or no encryption at all.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.