3

Today I got a bit of a nasty surprise with my mobile data and I am not sure how to correct it.

In my settings for the Play Store I have (and had for ages) download only on Wifi.

This month something has changed as my phone has gone over its data allowance and looking at the list of apps and usage the top bandwidth user is the Play Store on Mobile Data with 540Mb.

I do not understand why the Play Store is updating on Mobile data even though it is not supposed to?

Under the Wifi Usage tab the Play store is also the largest user of bandwidth, which I do expect as that is what is supposed to happen.

Any ideas why Play Store is running over Mobile Data?

  • Are you sure it was updating apps? The update setting only applies to automatic updates, not to anything Play Store downloads while you're using it (e.g. when installing new apps). – Dan Hulme Jun 9 '14 at 14:16
  • Not sure what the Play store app was doing. It was not installing any new apps as I have not added a new app for about 2 months. The mobile data graph shows a sudden increase about a week ago (A very sharp rise) and all the other apps have a bandwidth usage of around 6mb at most. – Peter Jun 9 '14 at 22:07
  • 1
    It could be the play store updating ITSELF as it does. There is no setting for this, only the 'auto update apps' as mentioned by Dan. – RossC Jun 10 '14 at 11:25
  • I've had problems with it updating itself in the past; I don't think there's any way to stop it either (it complains and refuses to show anything if you turn off background data for it). – user43185 Jan 12 '15 at 20:50
  • Duplicate of android.stackexchange.com/q/65445/36187 (Though the comments here are more useful - how often does play store update itself??) – Darren Cook Apr 27 '15 at 20:12
0

I had the same issue. The solution, which worked for me has been going to Settings → Data usage → Data Saving Mode. Besides switching this mode on and off, there is an additional menu called Unlimited Data Access, in which you can activate this feature on per app basis. In my case, Play Store was activated. Switching this option to off brought me over the hump and I am fine now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.