0

I have a 'Maguro' Galaxy nexus, purchased from O2 in the UK. I am now in the US on T-Mobile.

My phone was working fine until yesterday I flashed the most recent CyanogenMod nightly, now I get no signal. Under Network Operators I get a list of AT&T and T-Mobile but clicking either gets an instant fail.

I've now tried flash all kinds of Baseband to it, XXLJ1, UGLL1, TDVMK1 to name a few. I've tried installing the google 4.3, 4.2.2 and 4.1.2 images, all of which come with XXLJ1 - still no luck.

My previous ROM was a stock (but rooted) 4.1.2 (I think) , but I have no idea on the radio.

Any suggestions what I should try next?

Update: I've just checked my IMEI number and the one the phone reports no longer matches the one on the sticker :\

  • You tried flashing all three factory images through fastboot? If it was related to the ROM update, this should resolve it since it completely replaces the /system, /boot, /recovery, and /data images in addition to the bootloader and radio. So either the factory images didn't flash properly or it is a hardware issue. It could even be the SIM card. – abqnm Jun 10 '14 at 20:48
  • Yep, I flashed 3 stock roms along which included radios. I tried my wife's t-mobile sim also. Seems unlikely to be a hardware issue as it was working before I messed with the software – matt Jun 10 '14 at 21:53
  • This is caused by me inadvertantly wiping the /factory parition. My phone is now assigned the default IMEI number (004999010640000) which is blocked by T-Mobile – matt Jun 10 '14 at 22:08
  • Ok, glad you know the root. Just to let you know in some countries changing the IMEI is illegal, you may want to get that sorted quickly. It is sometimes used in phone cloning etc. – RossC Jun 11 '14 at 14:06
  • @matt do you still have any previous backups? The imei is stored in two places, /factory (the main source) and in /data/radio. When you do a factory reset it copies from /factory to /data/radio. If /factory is gone, it will use the generic one. If you can pull the nv_data.bin from a backup, you can push it back to the /factory partition with adb. Here is a guide. forum.xda-developers.com/… – abqnm Jun 12 '14 at 9:21
-1

I had the same problem, and the solution was to re-flash the stock ROM.

  • This won't help since it doesn't restore the files in /factory/. – onik Aug 15 '14 at 5:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.