1

I've installed Motorola USB Driver and enabled USB Debugging mode as well with MTP enabled.

The Issue is - The device hardly shows as available in Eclipse for << 1min time and after that it gets back to offline mode. I tried to do ADB command like Kill-server and start-server but there is NO effect.

And it comes back to online after so many ON/OFFs and disable/enable the USB debugging again and after all these efforts, the device again stays in debug mode for the same <<1 min.

I also tried it with PTP mode as well but no use.

Is this a known issue with Moto G or Am I doing something wrong?

My settings are like this under USB Debugging:
stay awake - On
USB debugging - On
Allow mock locations - On

Appreciate if somebody can guide me which will enable me to work with my Moto G and Android Programming.

1

I tried with a different USB Cable and it is working stable now.

Unfortunately Moto G doesn't come with USB cable as part of the accessories and hence we have to rely on the USB cables available in the outside market.

Currently I'm using Sony Xperia's USB cable which is working like a charm on my Moto G for USB Debugging. It's been couple of hours and the USB debugging is still on and going great :)

Let me observe the same for another day before I conclude the issue.

And another suggestion I received is - Do not work on Windows for Android Development but stick with Linux as windows drivers are buggy in most of the times.

I appreciate the suggestion as of now and may look at this option as well in the near future to switch to Linux for Android Development.

  • I'll second switching to Linux - when I was developing on Windows, I had to switch to emulators pretty frequently, as my devices just wouldn't connect. Switched to Ubuntu and haven't had a problem with a connection since. – camdroid Jun 12 '14 at 18:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.