3

At one point I had my Nexus 5 showing up in Device Manager on Windows 7 but now it will not show up at all.

Background:

  • I have Android SDK Level 22 installed
  • I have run SDK Manager and downloaded the latest Google USB driver
  • I recently go the Android 4.4.3 update. I am not clear if this was right before I started to have problems or right after so I am not sure if it is related or not
  • I have even installed the LG Universal driver
  • I have my phone in MTP storage mode, but have tried camera mode as well
  • I have tried turning on Developer Mode/USB debugging as well
  • I have tried 3 different cables
  • Windows never seems to even recognize that the device has been connected via USB - I get nothing, not even 'Unrecognized device' or 'Driver not installed'. No entry in Device Manager either

I've followed the many suggestions on SE and the web

  • make sure MTP storage is enabled (check)
  • try camera mode (check)
  • try Developer Mode/USB Debugging (check)
  • change cables (check)
  • Update the driver for the phone in Device Manager (The device does not show up in DM)
  • Remove old stale "hidden" android devices in Device Manager (check)

I'm out of ammo. Anyone have any ideas?

  • Does the phone think it's connected? There's a notification if it is. – Dan Hulme Jun 12 '14 at 17:25
  • Good point. It does not have the USB notification icon. Connectivity had been flaky a few days before this happened. wonder if the data channel on the USB is bad (it still charges when connected) – Mike Marshall Jun 12 '14 at 18:31
  • @DanHulme Bingo. I wiggled the cable then pushed it all the way to the left of my micro-USB port on the phone and it connected and was detected by Windows. Looks like I may be getting it replaced under warranty - this is the second android phone where the micro-USB port has gotten flaky (I had the original G2 that did this to me as well). – Mike Marshall Jun 12 '14 at 18:44
2

Thanks to @DanHulme in the comments. He asked me if the phone registered a connection in the notification bar and it did not. I wiggled the cable then pushed it all the way to the left and the phone was detected by Windows. Must be a dirty or failing micro-USB port. If cleaning it does not work I will be returning the phone under warranty.

1

There are apparently lot of cables out there that will charge the phones nicely but when it comes to data transfer will not meet the protocol needs and USB will not detect anything connected on the USB device driver to kick in at all.

I decided to try a new cable and lo and behold, two different phones immediately got recognized on Windows 7 (an LG and a Nexus) that were not working with other cables. So even though it sounds dumb, these darn cables are a major culprit (or the connector jack/pins rather).

0

I tried everything and then some. Different cables, different computers, but the Nexus 5 would not show up on the device list, the phone would not know it was connected, only charging worked. I examined the USB port for any visible obstruction or damage with a magnifying glass, but it appeared clean and in working condition.

Then I saw an almost empty can of Dust-Off spray sitting on my desk. I stuck the nozzle extender into the phone's USB port, sent a couple of blasts into the opening, et voila, it connected again.

Bottom line, there might be a mechanical obstruction causing this that it is not visible to the eye.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.