1

I bought a Chinese Android 4.2.2 smartwatch and discover it does not have a virtual keyboard. There is also no "input" option in Settings (there is "language" only).

I installed a third party keyboard (Anysoftkeyboard) and another app called Quick Keyboard Switch that can change keyboards with going through Settings.

When I run Quick Keyboard Switch and tried to enable the downloaded keyboard, the app force closed.

I found another post here describing how to use ADB shell to enable and set the default keyboard:

how to change input method with ime command

The instruction from the above post describes how to enable the keyboard using "ime enable com.etc.etc" command before setting the keyboard as default using "ime set com.etc.etc"

Unfortunately, when I use the "ime enable" command in ADB shell ("su" applied, the watch has been rooted), it gives me an error message:

Error: Unknown ID: null

When I use "ime set" command, it returns a similar error message ("com.etc.etc" (name of keyboard) instead of "null") - I gather this is because I have not enabled the keyboard yet.

I am worried that I don't even see "keyboard" option in Settings - does that mean the input module has been removed by the firmware maker of this smartwatch?

If so, where should I look in the Android firmware (I guess somewhere inside /system) that I can copy and paste to restore the keyboard input function?

I am NOT a developer nor a computer engineer. I google and try to find solutions to my problems. Thank you for your help and being patient.

1

It sounds like your suspicion is correct, and the manufacturer has removed this functionality from the firmware. I'm afraid it's not as simple as copying and pasting some files: you'd need to obtain the source code of the firmware, modify it, and recompile to add the functionality, and likely you'd need to overcome whatever problems made the vendor disable it in the first place (such as that keyboards aren't made for such small screens).

  • Thanks for the quick response. I guess this is well beyond my ability to fix the problem. Some smartwatches do come with virtual keyboards, and I have installed and used keyboards (eg Anysoft, Flit) on smartwatches eg. SmartQ ZWatch. I guess the manufacturer of this particular watch decides that either BT keyboard or phone keyboard (using the watch as a phone companion) is the way to go. – KaC Jun 12 '14 at 17:55
  • Dear Dan - I found Settings.apk in /system/app. Is this the apk that controls "Settings" menus which should have included "Language and Input"? I know there is an apktool that can decompile / compile apks, but I have no knowledge of how to make the repair to restore access to onscreen keyboard input. – KaC Jun 17 '14 at 6:02
  • I have the logcat when the kyeboard switching app force closes: 'uncaught exception occurred W/System.err(16742): java.lang.RuntimeException: Unable to start activity ComponentInfo{com.android.settings/com.android.settings.Settings$InputMethodAndLanguageSettingsActivity}: android.app.Fragment$InstantiationException: Unable to instantiate fragment com.android.settings.inputmethod.InputMethodAndLanguageSettings: make sure class name exists, is public, and has an empty constructor that is public W/System.err(16742)' – KaC Jun 17 '14 at 6:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.