1

Background:

I was previously rooted and even after disabling root I could not do the OTA (it kept giving me a status error 7). After researching I decided to use ODIN to try and restore to a stock ROM for the upgrade.

I initially tried to use CI605_I605VRLJB_I605VRALJB_CL414933_HWID04_HW_Rev0406_low_ship_user as the firmware, but it caused my device to go into a firmware upgrade error.

I then used I605VRUEMJ9_I605VZWEMJ9_I605VRUEMJ9_HOME which got me back to stock 4.2, I OTA'd to 4.3, and using a previously downloaded OTA copy of 4.4.2 I booted into recovery mode and manually installed the OTA.

The Problem:

Since going to 4.4.2 (and I noticed it in 4.3) the Google Play store seems to load EXTREMELY slowly. I have Frontier FiOS and speed testing the connection shows a minimum of 25/11.36 Mbps for my connection. 4G does not appear to work so well either.

Could I have messed something up? I do not know why my stuff is working so slowly...

EDIT

I tested speeds using SpeedOf.Me (website version) and got results of .5-1Mbps DOWN and .5Mbps or less UP. This is regardless of using wifi or 4G. I tested Wifi on my PC and got more than 10Mbps.

  • Did you flash an updated modem/baseband? One that is for Kitkat? That may be the source of the issue. – RossC Jun 13 '14 at 11:51
0

Take it to the samsung care and fresh install the kitkat rom all your problems will be solved. If you don wana go to samsung care go to sammobile.com find the suitable firmware and flash your device using odin.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.