0

I have an Xperia L mobile , I'm from India and having AirTel Network Connection. The problem is on the mobile network icon,it shows Roaming Symbol since I'm in home network.I made a call to the customer care,they replied that the problem is not on their side (they haven't charged for Roaming). Can anyone help to get rid out from the issue.

Does keeping the mobile data on for all time have an impact on battery ?

  • have u tried formatting your phone.it'll solve your problem. – JerryGoyal Jun 22 '14 at 15:41
  • yes, problem still presists – Sukan Jun 23 '14 at 3:31
3

Basically roaming icon comes on two chances,

When you are in the different state. When you are in the same state but in a union territory or capital of the state(only in few states)( like : Airtel,Vodafone treats Chennai as one place, Pondicherry as one place and rest of Tamil Nadu as another place. So if I buy a SIM from some city other than Chennai in Tamil Nadu and when I move to Chennai, the "R" symbol appears.).

So, you don't have to worry. You wont be charged. And it doesn't drain your battery. And you can keep your mobile data on, it wont make any difference if you are in roaming or not. Mobile Data wont charge you extra.

| improve this answer | |
  • ok,mentally felt that my internet was not smooth on Roaming,Nevertheless no issues regarding Roaming. – Sukan Jun 13 '14 at 10:14
  • If you're satisfied that this is the right answer, accept it by clicking the green check mark on the left. You get some rep for that, and other visitors can see that this question has been answered. – RossC Jun 13 '14 at 11:45
  • Awarded! Though it doesn't solve the issue,since a good answer in the cards. – Sukan Jun 27 '14 at 7:19
0

I don't think its the phone's problem as Roaming Icon on Home-Network is also reported by other Airtel users, using different phone manufautures . This occurs especially on areas with lower range or between two towers. Switch on to flight mode, then offing it seems to fix the problem. I think Airtel sometimes uses other service providers network.

| improve this answer | |
  • I tried by putting it in the Airplane mode,but still roaming icon is present – Sukan Jun 23 '14 at 3:32
  • @Sukan, Try: Search for the available networks then select your home network (i.e Airtel ) – totti Jun 23 '14 at 14:22
  • no use in that. – Sukan Jun 25 '14 at 7:12
0

You can manually change the roaming settings from

Settings>>More networks>>Roaming>>Roaming settings.

It will not affect battery or data package

| improve this answer | |
0

Well @Sukan you would understand that the network of cellphone depends purely on the proximity of the tower situated by.

  1. A Subscriber is identified as Roaming if he/she has moved to another circle (receiving signals from the tower of another circle).
  2. Due to this it might be possible that your device is on the border of two circles.
  3. So if you move toward the inner tower then it will not display any roaming but if you move even slightly away from that tower then it will receive the signals from the tower situated near to you but connected to another circle thereby showing Roaming on your display. This is weird but normal part of mobile technology Hope this solves your doubt
| improve this answer | |
0

This was happening in all my Xperia phones ( mini pro, U, Z1). For example in TamilNadu, the mobile operator will have two circles. 1. Chennai, 2. Rest of the TamilNadu. When you move from one circle to another circle, your mobile signal will show R.

This means you are not in Roaming, you just moved to another circle of same state. You wont be charged for roaming.

This was not happening in 4.4.2 update of my Nexus5. But when I updated it to 4.4.3 the same thing happened.

However I didnt find this in my friends htc explorer.

Its also been found by few Xperia L users that the Tata Docomo and Airtel sim will show R even in home network.

| improve this answer | |
  • But I'm not in chennai, – Sukan Jun 27 '14 at 4:50
  • how is the data connection,whether it is smooth? – Sukan Jun 27 '14 at 4:51
  • @Sukan, I just took TamilNadu as example. Similarly you will find in other states too. The data and battery backup is all same – samnaction Jun 27 '14 at 5:06
  • ok.I'm in TamilNadu too. – Sukan Jun 27 '14 at 7:18
0

All of the answers here seem to focus on India, so I thought I'd give a more global explanation.

Each mobile network has a Mobile Country Code (MCC) and a Mobile Network Code (MNC). A SIM card has a single home network, which is identified by a MCC/MNC tuple, a combination of these two. A Roaming network is identified by a differing MCC/MNC tuple.

Usually a single carrier has a single MCC/MNC tuple in use, and the same network is used for all SIMs. However, in some cases, a network can use another carrier's network but still act as a home network. Usually this is the case with MVNOs (Mobile Virtual Network Operators). They lease the network from the actual owner under their own brand. One example of this is the Finnish Saunalahti, which leases Elisa's network.

In India (and a few other large countries), each circle has a separate MNC for each carrier, which results in the situation you've described. If a SIM has a home network in a circle (e.g. Vodafone in Chennai has the MCC/MNC 404/84), when the phone moves to another circle (e.g. Karnataka 404/86), the tuple doesn't match and roaming is shown. However, since both networks 86 and 84 are Vodafone's, no roaming charges are added.

If the phone shows roaming even in your home network/region, it's possible that the SIM has the wrong circle's home network MCC/MNC tuple.

The differences between devices can occur if some devices check the HLR (Home Location Register) of the carrier to see if the SIM is in a "home" network (i.e. a different MCC/MNC but the same carrier) and some jump to conclusions based on just the MCC/MNC values.

References:

| improve this answer | |
  • When you move to karnataka to chennai, roaming charges apply. Its a different state. – samnaction Jun 28 '14 at 4:19
0

I had the same problem. THen I checked the mobile networks settings and in that there is a option called "preferred network", In that my local state priority was changed to 9 somehow, I have then reset the priority to 1 and roaming symbol went off

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.