71

I'm using Android 4.4.2 (on Micromax Unite 2 - A106). I've a Windows PC at home which has highspeed broadband internet connection. I don't have wireless router or access point. I just want to use PC's internet connection on my phone. I've tried multiple methods but none seems to work.

Method 1: Using native Android 4.4.2 option

In my phone when I connect my phone, in Settings > Wireless & networks > USB Internet (sharing Windows PC internet via USB cable) checkbox, which I checked then it asked me to choose my Windows version (which is Windows 8.1 but since it didn't show that option) I chose Windows 8. It gives me further instructions as showing in the following picture:

enter image description here

Here is the problem, there is no sharing tab (see the following screen shot) enter image description here

Method 2: As described in How to setup reverse tethering over usb

I learned on this site that it is called Reverse tethering. I read and followed the procedure mentioned in How to setup reverse tethering over usb

I followed all the steps described in that answer, until executing the command.

  1. Install USB drivers from Android SDK [DONE]
  2. Connect USB cable and activate USB Tethering (You should see on a new network interface.) [DONE]
  3. Bridge the 2 network interfaces [DONE]
  4. On your computer execute adb shell netcfg usb0 dhcp [PROBLEM]

When I execute adb shell netcfg usb0 dhcp it says: error: device not found. I tried the same thing with USB Debugging in Developer settings, ON & OFF. The error remains the same.

Method 3: Rooting the device and using an app

I read here and there that there is another method, in which we can directly use an app but it requires rooting the device. My phone is a new phone and warranty becomes void if I root it.

EDIT: I've tried the method suggested in answer, at the 4th step of method 2, I'm facing this problem:

enter image description here

  • For the first method, if you can't find a sharing tab in the network properties in Windows, then you could post a question to our sister-site superuser.com (they deal with problems with PCs and Windows) asking why you can't see that tab on your network properties in Win 8.1. – GAThrawn Jun 18 '14 at 11:56
  • U can do it by reverse USB treating – Maveňツ Jun 23 '14 at 8:07
  • 1
    For method 2, step 4, have you enabled USB debugging? adb won't work without enabling it – ᔕᖺᘎᕊ Jun 23 '14 at 19:30
  • 2
    I wasn't able to find Settings > Wireless & networks in my Galaxy S5 from T-Mobile. It is also Android 4.4.2 as yours. Ideas? – Tagar Sep 12 '14 at 20:49
  • 1
    I also could not find the native option on my device. I did not want to root my device, so eventually, I developed my own solution, ReverseTethering NoRoot (play.google.com/store/apps/…) – FD_ Feb 25 '16 at 17:35
28

Actually, Method 1 is quite easy to do. As implied by this answer, you need more that one network connection for the sharing tab to appear.

Short Answer:

First, ignore the instruction of your android device and try to connect to the USB-Internet anyway.
This will create a new Network connection and allow the sharing-tab to appear on your PC Network Connection.

Detailed Answer

1. Prepare Windows 10

  1. Rightclick the Windows-Start Button
    The Windows Start Button
  2. In the opening Context-Menu, open "Network Connections"
    "Network Connections" in the Context Menu
  3. The Network Connections will show up. As you can see, there's currently only one Network connection, so there will be no sharing Tab.
    enter image description here

2. Prepare your Android device

  1. Connect your Android device with a USB-Cable to your PC
  2. In the Wireless & networks section (you might need to click on "More..." on some android devices), Try to activate the USB Internet
    Activate "USB Internet"
  3. Instructions will appear. Select Windows 8 and just click on Next and Done, ignoring the given instructions
    Select Windows 8 and Click on Next Click on Done ignoring the steps
  4. Now, there should be a check-mark after USB Internet:
    USB Internet should be now checked
  5. If this is the first time you are connecting your Android device to your PC with a USB-Network, Windows might ask you whether to grand the Network connection. That's normal.

3. Share the Internet Connection on Windows 10

As you can see, there are now two Network connections, so the sharing Tab will be now available:
Two network connections

  1. Right-click the first Network Connection and open the Properties Open the Properties of your original Network Connection
  2. Now, there's a Sharing Tab and you can Allow your Android device to use the Internet connection of your Windows 10 PC
    The Sharing Tab is now available
  • 3
    I can't verify this (no windows here but those for light and fresh air) – but still upvoted: very thorough and visual explanation, thanks for sharing! // PS: Now you can answer even protected questions :) – Izzy Aug 15 '15 at 13:41
  • 3
    Hmm, I don't see this "USB Internet" option on Android 6.0. Do I need to do something else before it shows up, or does it work differently in 6.0? – ProgramFOX Sep 18 '16 at 15:23
9

For your second method (which should work) it looks like you are just missing the correct drivers for your device. I found a page which claims to have the drivers (http://www.digitbrunch.com/android/how-to-root-micromax-unite-2-a106) although I cannot vouch for their authenticity so its up to you if you want to trust them.

Let me know if you run into any problems, because although I have never done something like this before I would be happy to help you through it if I can.

  • I've posted the edit after trying out what you suggested. Please check it out. I've tried the method suggested in answer, ar the 4th step of method 2, I'm facing this problem – claws Jun 15 '14 at 4:51
  • Sorry for the long wait on the response (hell week at school right now), but the error seems to be that adb can't see your device. Now usually its a driver issue when this occurs, but there is also a chance that it could be a hardware problem (my nexus 7 for example can't connect to computers anymore). What is the output you get when you run "adb devices"? – Colin Jun 17 '14 at 12:56
  • Also this thread may prove useful: forum.xda-developers.com/google-nexus-5/help/… , its for the nexus but it might have some more information if your driver isn't the problem – Colin Jun 17 '14 at 13:08
5

There is a solution for unrooted devices

I know this is a late answer, but as all existing answers suggest that USB reverse tethering is only possible if either your device is rooted or has system support for reverse tethering, I though it'd be worth pointing out there's one more option:

A few months ago, I was looking for a solution that would allow me to use my laptop's Internet connection on an unrooted Android device, but I just couldn't find a solution. Eventually, I started to develop my own solution. The result is an app that works on devices running Android 4.0 or higher on client side, and all major desktop OSs on the host side.

The ReverseTethering NoRoot app

The app is available on Google Play: ReverseTethering NoRoot

3

I am also using a Micromax Unite 2. What works for me is the first method.

It seems that you are not connecting your device (phone to PC). So it doesn't show you the sharing tab. You only have a LAN device but no device to share.

So, first you need to connect your device to the PC and, then, proceed with the remaining steps. I am really enjoying the Internet from my PC to phone!

Procedure

  1. Connect your mobile to the PC via a USB cable.
  2. On your mobile, go to Settings->more->USB Internet, select PC system version->next->"DONE"(IMPORTANT).
  3. On the PC, go to control panel->Network and Internet->Network connection.
  4. Here, one of the devices is your LAN Device and another one is your mobile phone.
  5. Right click your LAN device go to Properties->choose the "sharing" tab->click on the first option->ok.
  6. Now you are ready to enjoy Internet on your phone.
  • Please avoid txtspk. For some non-native English speakers, it's hard enough without :) I've fixed that up for you here. – Izzy Aug 2 '14 at 16:10
2

I tried to do the same thing and like you said "Here is the problem, there is no sharing tab"

But I found a section in Windows assistance saying that there is no "sharing tab" if you have only one LAN connection.

Here is the URL: http://windows.microsoft.com/en-us/windows/set-internet-connection-sharing#1TC=windows-7

2

I tested first method on ZTE V987 with android 4.2.1 and, after a little search for RNDIS Interface and another MTKandroidUSB device (ADB Interface) drivers (for windows Xp), it worked. I think you don't have the phone drivers installed in windows. Have you checked in Device Manager?

I have tested first method also in Windows 7 and I installed the following devices:

MT65xx Android device

then I have shared the Internet connection, but without success. The phone did not want to see the connection. Then I have changed the drivers with those from http://www.digitbrunch.com/android/how-to-root-micromax-unite-2-a106 (Driver_Auto_Installer_v1.1236.00) and I have tried to bridge the 2 network adaptors and I have obtained next configuration: Driver_Auto_Installer_v1.1236.00

Then I have reverted to Internet Connection Sharing and I have tried the following commands (found here http://forum.xda-developers.com/showthread.php?t=2287494) : adb shell netcfg rndis0 dhcp

And the phone's USB connection began to operate:

Lan3Status Lan3Details

Finally I have re-updated the usb drivers to the initial Alcatel version, deleted MAC Bridge Miniport, set same DNS for IPv4 RNDIS Local Area Connection and used a .cmd file with adb shell netcfg rndis0 dhcp command to start the connection.

Lan3Details2

protected by Community Sep 8 '14 at 14:25

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.