I already soft bricked my Samsung Galaxy S2 GT-9100M two times (the M is important, it's Virgin/Bell Canada's version) when trying to install clockworkmod recovery (CWM) on it.

First time I think I flashed "GT-I9100_JB_ClockworkMod-Recovery_6.0.2.9" file via "Odin3 v1.85" (have two tars sitting here, could have been the other one), found at some Youtube video. My phone was previously rooted via framaroot.

Second time I tried GalaxyS2Recovery.zip from this page.

Both of the times the phone could not go through a normal boot procedure, so I had to go into download mode and flash Samsung original image (which I got from sammobile.com).

The phone is now working fine.

If it helps, I was able to flash Jeboo kernel, as suggested in some other tutorial, but it may have been overwritten when installing the original firmware (not sure how Odin works to that level of detail). It did not seem to help flash any of the clockworkmod recoveries I tried.

Did I miss any steps? Is it simply not possible to flash CWM for Canadian version of this phone? Another thing - most of the CWM images are ZIP files, and Odin needs TARs. Is there a better flashing program that works with ZIPs? Or is it possible to convert ZIP -> TAR? I was getting ZIPs from https://www.clockworkmod.com/rommanager.

I also tried ROM manager APK, which is supposed to load CWM via easy to use interface. It prompts to confirm my phone model, when I pick i9100 it says "not supported", also tried "galaxys2" it attempted to install something but failed. Reboot worked after that, so at least it did not break anything.

Any help is appreciated.

1 Answer 1


I ended up flashing custom kernel from here (for "#1.8. Android Version 4.1.2, Jelly Bean."):

Then I was able to attempt installation of CyanogenMod 11, snapshot M7, which did not work (but that's another story). Just leaving this note here if anyone comes from google search with the same problem.

The corner stone was that I expected my phone to enter recovery mode with [home] + [volume down] + [power] combo, i.e. that CWM recovery overrides download mode. In reality, these two modes are independent of each other. To enter recovery mode, use [home] + [volume up] + [power]. You do not need CWM to enter recovery mode, but the default feature set is limited, so yes, better get CWM.

Regarding CyanogenMod 11 installation, according to another question here on android.stackexchange, it requires CWM v6.0.4.5 to run. Problem is that officially CWM does not support my Samsung Galaxy S2 i9100M (and even the version I am supposed to download for a generic/international S2 off their website is like v5.8.x.x), so I would need to find a custom built CWM. CWM completely replaces the default recovery mode.

Tried latest Philz touch, but it did not work. Actually it did not work so badly, that I had to

  • flash original image from Samsung (sammobile.com).
  • go in recovery, clear data (factory reset), clear cache.
  • make sure the OS starts (goes into init/setup mode - after factory reset).
  • flash custom kernel Siyah-s2-v6.0b5.tar, do CWM restore, to bring phone back to shape.

For reference, in my attempt to install CyanogenMod 11 I soft bricked my phone 9-10 times already, with a total of 1 full working day spent on this campaign (8 hours).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .