I have some simple digital camera for my kids with only internal memory. I do have some windows software for it to import the photos. The windows software looks a bit outdated, but it works.

When I connected it on an Ubuntu machine to read the USB ID ("ID 0979:0227 Jeilin Technology Corp., Ltd JL2005B/C/D Toy Camera") it worked instantly. The memory was mounted as a drive, I could see the photos and copy them!

But when I go on holiday I will have neither a Windows PC nor an Ubuntu machine nearby. I will only have my Samsung Galaxy Note 10.1, which supports USB OTG.

When I connect the camera via the USB OTG connector, the camera gives a bleep and on my tablet I see a message "USB connector attached". But I don't see a mounted drive (which I do see when I connect a simple USB memory stick).

Is there some kind of app to import the photos from a digital camera?

Regards,

The camera may be connecting on PTP (Picture Transfer Protocol) or MTP (Media Transfer Protocol) mode, not as a normal USB drive (which uses USB Mass Storage drivers). It shows up in Ubuntu similarly to a USB Mass Storage device, but Android has no support for this out of the box.

You could try an app that supports PTP, such as DslrDashboard, but I haven't tried these personally, so no guarantees.

  • Thanks for your answer. The camera is a very simply thing, produced probably during the Windows XP era. Do you think it will support PTP or MTP then? – ffonz Jun 19 '14 at 8:42
  • Sorry, no luck. I cannot see the camera with DslrDashboard. – ffonz Jun 19 '14 at 21:51
  • @onik: AFAIK, MTP and PTP are available when Android becomes slave and PC becomes host. In ffonz's question, Android is the host and camera is the slave, so I don't understand how come PTP and MTP would be available other than OTG USB Storage mount. Care to explain. – Firelord Mar 10 '15 at 19:41
  • @Firelord If the camera itself supports only MTP or PTP slave mode, it needs a host that can act as a MTP/PTP master. I don't mean the USB connection mode in Android settings, but an app that emulates a MTP/PTP master. – onik Mar 10 '15 at 19:46

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.