0

I'm trying to use my Note 3 to help me debug a website, but I just can't get it going. I've enabled developer mode and checked USB debugging in developer options, but that's as far as I can get.

I've installed Kies 3 and when I connect my phone using a USB 3 cable to a USB 3 port I can see my phone in Kies, I can transfer files to it and everything. I can do this using Windows Explorer or Kies.

However it cannot be seen by ADB or Chrome Inspect. Going through the instructions online they say I should be getting a popup asking me to authorise remote debugging, but I'm not getting that.

I've tried everything I can think of, I'm new to debugging mobiles and so my knowledge on how to get this is limited. Can someone help me get this working please?

  • If you unplug your device, reboot, does it still not ask you for permission? You're sure you have usb debugging on? Not trying to insult your intelligence, but I've had similar problems with android devices (particular the note and note 8), and sometimes I have dev mode on, but I forgot to scroll down and check "usb debugging". I don't recall of windows has the android transfer tool, but make sure that is turned off too if it's on. The other thing is on adb try to kill and restart the server. Can't think of anything else. Have you tried any of these? – pqsk Jun 19 '14 at 18:43
  • Definitely have usb debugging checked and rebooting does nothing. I've killed and restarted the adb server multiple times, both removing the usb before and leaving it plugged in during the restart. – Styphon Jun 19 '14 at 20:32
  • Interestingly, I've just tried this from my home PC and the prompt came up. I can view it in adb and chrome://inspect too. It must be something about my work PC but I wonder what. – Styphon Jun 19 '14 at 20:54
  • it could be the ports are blocked. Maybe you could verify with network admin, perhaps to confirm? Other than that I would recommend bashing your work computer it until it works. lol j/p – pqsk Jun 20 '14 at 3:47
  • Hehe, we're a small company and I wear many hats, including network admin. There's no reason why the USB ports should be blocked. – Styphon Jun 20 '14 at 6:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.