Does anyone know how I can enable ext2 or ext3 partitions on my LG Optimus V? I have already partitioned my 16GB SD card to 14.5 GB FAT32 and 500MB ext2. When using Link2SD it gives me a mount error. I am rooted but have not flashed any ROMs yet.

  • what's the mount error message? – Lie Ryan Apr 17 '11 at 19:23
  • 1
    Have you tried ext3 instead of ext2? It may be better supported. – Logos Nov 14 '11 at 22:21

I think your ext partition must be a primary one NOT logical - check to make sure that's the case.

  • I created my partitions using parted and specifically chose "primary" as the answer, so that shouldn't be the problem. – haridsv Jun 30 '11 at 23:18

I am not completely certain what you mean when you say enable, so this might not answer your question.

Filesystem support is determined by the kernel, so if the kernel was not compiled with support added for a specific filesystem, you cannot use it. That being said, all android devices I have fiddled with have had support for ext2/ext3 compiled in (I think all Gingerbread devices must have support for ext2/ext3 since they are starting to use it on the eMMC flash instead of YAFFS2).

In order to check that ext2/ext3 is working correctly, I suggest you connect your device to a PC and log on via 'adb shell'. From there, create a mount-point (for example by doing 'mkdir /mnt/tmp') and try mounting manually. SDcards usually end up as /dev/mmcblkXpY, where X is the device number and Y the partition number. Try mounting by doing 'mount -t ext3 /dev/mmcblkXpY /mnt/tmp'. If that works, and you can read and write to /mnt/tmp, ext3 is working as it should.

  • I have the same issue as OP and tried to follow your instructions. There is mmcblk0p2 device in /dev/block and I tried to mount, but I got an error "mount: No such device". Is there another way to check if ext2 is supported? – haridsv Jun 30 '11 at 23:17
  • Same problem here. I have an mmcblk1p2 in /dev/block giving the same error, both in the adb shell and in the onboard terminal. – user140691 Dec 9 '15 at 22:50

Some cards do not support creating ext2 partition larger than 6.5 GB (I faced the same in 64GB SD card). Try Mini Tool Partition utility. Once it completes the ext2 partition format, you should not see other in the partition type space holder. It should be ext2. If it shows other, it will never work in the phone. Try reducing the size of the fat32 gradually and create ext2 after that.


I want to mention that user must use CWM recovery for partitioning SD Card and then swap, after that mount as ext2 or ext4 but not ext3 with Link2SD. Check if this works for you.

  • The SD card can be partitioned on a PC using GParted as well, or on-device using AParted. In fact, the 1st is what I did when I used Link2SD. Please note that your answer, as it stands, is probably incorrect. – Tamoghna Chowdhury Nov 21 '15 at 10:17

In Google Play exists EzyMount, a tool with which you can mount and make accessible devices formatted with NTFS, Ext2-4, etc. for Android 2.3 and greater.

  • EzyMount requires a rooted phone with busybox installed, so please don't try installing it unless you have root. – user159844 Apr 6 '16 at 17:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.