I love Android and have been a proud Nexus One owner for over a year now. I was also really excited when Gingerbread dropped and flashed my phone before the OTA update (who can wait for these things anyway).

However, since upgrading, Gingerbread has not been the bliss that I had hoped for.

The first thing I've noticed is that the new keyboard seems to freeze every other day rendering any app that uses text input unusable. This causes me to have to reboot my phone (or at the very least end the keyboard process).

I also started to notice that since my upgrade my phone will sometimes stop syncing with my work's Exchange server, causing me to miss emails that I used to get while not at my desk (again a reboot seems to fix this). I tried removing this account and re-adding it only for it to continue happening.

After these initial complaints some of my friends, also Nexus One owners, have started to report similar issues. One such friend says that his home screen icons will stop displaying leaving him with only his background to look at after pressing the home key. Another friend says that he must reboot his phone every day, at least once a day, due to his keyboard not working.

In general, though, the internet does not seem to have any reports of these kinds of issues outside of my few friends.

Have any other Android users out there noticed these or similar issues with Gingerbread? Does anyone know of any possible causes?

  • I'm really interested in a fix for the keyboard issues too, the same thing happens to me far too frequently. Any updates? 2.3.4 hasn't solved this issue at all.
    – wsanville
    May 16, 2011 at 17:19
  • @wsanville unfortunately I still have not found a solution to these things.
    – MarkB42
    May 18, 2011 at 18:03

1 Answer 1


First, make sure you're updated to Android 2.3.3. .3 has some stability improvements over 2.3.1 and 2.3.2.

The other thing I would try is a factory reset. Upgrading can be a pretty messy process and you want to make sure you don't have any bad data left over.

  • 1
    yes 2.3.3. Also the other day I was playing around with my phone and ended up doing a wipe from the bootloader which I would think is comparable to a factory reset. The issues persisted after that.
    – MarkB42
    Mar 24, 2011 at 20:47
  • Did you clear the Dalvik cache? That might help as well. Mar 24, 2011 at 20:51
  • Thanks for the advice, I will try it and see if it helps.
    – MarkB42
    Mar 28, 2011 at 1:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .