I own a LG Optimus One with Android 2.2.2. Everytime I try to use the navigation provided by google, my phone remains stuck on Checking navigation availability. Is there a fix for this?

  • Is your GPS turned on? Mar 24 '11 at 21:55
  • Wifi probably needs to be on, too.
    – ale
    Mar 25 '11 at 0:14
  • You might try clearing the app data and/or cache and see if that helps.
    – ale
    Mar 25 '11 at 0:15
  • Both GPS and Wifi were on.
    – Geo
    Mar 25 '11 at 6:29

It seems I was running the 5.0 version of google maps. I tried to search for an update on the market, but I couldn't even find the app. The most surprising thing was that using the exact search strings, I was able to find it very easy in the browser.

I downloaded the 5.2 apk, and I installed it from the SDCard. Afterwards, everything worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.