Starting at exactly 3pm (EST) on Sunday two weeks in a row my phone could not receive SMS text messages. It could send SMS, send and receive calls, and send and receive MMS (mutli-media messages). I was using the stock messaging client. This is on an Samsung Rugby Smart running Android 2.3.6, with AT&T as the carrier. How do I get text messaging to work again?

7 Answers 7


Quick Answer:

Put the SIM card in another phone for a few minutes to reset the network registration and then move it back.

Things that I tried that did not fix this problem:

  • Restarting the phone
  • Removing and reinserting the sim card
  • Uninstalling the Skype app
  • Calling AT&T support (611) and asking for them to reset the network registration of my phone
  • Restarting my phone in safe mode
  • Booting my phone into system recovery mode and wiping the cache partition

Full Answer:

AT&T indicated that it was a problem with the network registration, given every piece of my phone's communication worked except for receiving SMS. This turned out to be true. The solution was to put the sim card in another phone, which overrode the network registration for my number. After about a minute, the second phone received all of the texts that the first had not been able to get, and then I could move the sim card back into my regular phone and receive texts as normal.


I encounter this issue every couple months. What always resolves the issue is resetting the radio. You simply enter a code in this format: ##code#.

iPhone radio reset: ##25327#

you might try this first: ##873283#

LG Optimus G radio reset: ##72786#

these codes are likely manufacturer specific so look up your manufacturer radio reset.

These codes were eventually given to me by Sprint after the other things failed. The troubleshoot flow typically is to update PRL, update profile, restart phone (none of which fix the problem) and finally these codes (which always fix the issue).

  • 1
    Where do you enter the code?
    – Zags
    Dec 15, 2014 at 18:17

I had the same problem of not receiving text messages from some of my contacts. I went to the T-Mobile store and asked for their help. They guided me to enter in to the SPAM area and found that some of my contacts were on the SPAM list. After removing them from the SPAM list, my problem was solved.

Go to your home page; tap on messages; tap on bar setting button lower left corner of phone which will bring up screen with a a spot called "Setting" ; Tap on "Settings" and scroll down to Spam Settings; This Setting should be unchecked, if checked, check under Spam settings to see if any phone numbers or phrases have been entered. All should be removed, phone numbers and phrases. The section for Spam settings should be unchecked.

Hope this is some help.


This happened to me too and I've just found the answer! I had accidentally added my daughter's number to spam, meaning I could text and call her but couldn't receive her text messages in reply. Open the messages app, click on left menu key, Second last option is 'spam messages'. Opening this will show you all the messages you have missed. Now long touch on a message and choose 'remove from Spam'.


I had similar experience. Unfortunately, the only way to fix the problem was to clean the whole phone (reset all data / factory reset). I guess some system internal database file was messed up. Before wiping all data I tried to only wipe Messaging app and the SMS storage + rebooting the phone.

If you need to do factory reset, try to backup as much as possible from all apps first. Unfortunately, without rooted phone, the backup will always be partial.


All there is to do is send someone a text who doesn't have an iPhone and it will automatically turn itself back on. This just happened to me.


All you have to do is remove your SIM and put it in another phone with the same carrier. Leave it in the other phone for a minute or 2, then put it back in your phone and it will work again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .