16

I have a Wireless Router (D-Link) in my living room and a repeater (TP-Link WA750RE) in my kitchen. Sometimes when I go to the kitchen and back into the living room, my Nexus 5 (Android version 4.4.3) doesn't switch to the D-Link router although it has a stronger signal. It stays connected to the TP-Link repeater instead.

Screenshot

When I switch wifi off and on again, it connects to D-Link Router, which provides much better speed. How can I force android always switch to the strongest signal? Is there a setting for it or an app?

  • As far as I know, you can only ask it to avoid a poor connection in the advanced section of WiFi settings, but not necessarily force it to connect to the strongest. – 1990clb Jun 23 '14 at 21:35

10 Answers 10

6

You could use Wi-Fi Manager. In its settings, it has Switch to best network.

  • I never used Wi-Fi Manager but I can assume it doesn't switch between APs that have the same SSID (aka repeaters) because at the hardware level Android only provide one MAC address to apps under a SSID. – Aero Windwalker May 16 '16 at 8:56
4

Android 4.x will connect to the strongest available network when first connecting, but, by default, once connected it will not change networks unless it loses its connection first. This is presumably because switching would involve disconnecting existing connections, and a second or three of no network.

If you turn on "avoid poor connections" in the Advanced wifi settings then it will switch if the network reaches a low enough signal to trigger this feature, instead of waiting until it is gone completely.

One solution might be to set up a single SSID with two access points that support hand-off, rather than two entirely seperate wifi networks - which is the way that this sort of scenario is handled in large commercial settings - but I do not know whether that is feasible with the hardware that you have.

  • Actually, both of these devices have indeed the same ssid. As I said in the OP, the tp-link is just a repeater. – ercan Nov 17 '14 at 10:53
  • Are you sure? I'm not a networking expert, but it looks from your screenshot as though there are two networks with two SSIDs (one called "TPLink" and the other called "Dlink"). Presumably the repeater is creating a second wireless network, and bridging between the two? – Flyto Nov 17 '14 at 12:24
  • Actually those are the aliases I assigned in the WiFi manager app so that I can recognize the devices on the graphs. Sorry for confusion. – ercan Nov 17 '14 at 13:44
2

Hate to break this to you but most Android phones removed auto switch feature for APs having save SSID because...wait for it...its an Apple patent...

  • 2
    Can you give any support for that? – Questionmark Jun 24 '16 at 14:02
2

For resolving switch APs that have the same SSID (using repeaters) I use with success "Roaming Wifi Fix". When signal level drops below a set threshold of settings, it automatically switches to the one with the strongest signal (sorry for my bad english language)

  • 2
    Could you add a link to the app you're recommending? That would be helpful. – Dan Hulme Jul 18 '16 at 7:26
  • Might be this one: heleron.com/android-apps.html Developer is clear about what circumstances the app is intended to work in, and when not. By description it is a perfect fit for this question, though there is note about some phones not supported. Switching APs does not appear to be seamless, the network is turned off and back on to hop. – matt wilkie Aug 1 '16 at 4:54
  • Google Play link: play.google.com/store/apps/… – matt wilkie Aug 1 '16 at 4:55
1

I just look into this question and combine 2 apps "Wi-Fi Manager" (which can give priority to 5Ghz network over 2.4Ghz) and "Wifi Roaming Fix" (which can choose best AP signal once roaming) FYI, my main router is dual band A/N while my repeater is only N for other side of the house. My setup is A band: use different SSID to N band so "Wifi Manager" can give priority to it. N band and its repeater: Same SSID and channel so "Wifi Roaming Fix" can do roaming one client moving around. I test with VOIP app and my mobile phone work smoothly all over the house w/o drop/reconnection.

0

You can use SWIFI, which detects a weak wifi signal and automatically switches you to a better network.

  • I use SWIFI too and it is a good app, but the problem with it is that it doesn't switch between APs that have the same SSID (aka repeaters). – Aero Windwalker May 16 '16 at 8:55
0

I seem to be having a similar but opposite problem with Fios, Orbi and 2 satellites and an LG V10 phone. Orbi is set as access point and everything has the same SSID. As soon as the signal strength falls even a little below -65, the LG drops out for 2 to 3 seconds and then finds it's own way back to the strongest signal, which is usually the closest satellite. BUT this is just enough time to lose a phone call I'm in the middle of.

The Android App Home Wifi Alert provides good detail re signal strengths and a great deal more information about my network. Using this is how I was able to see exactly when/where the signal dropped and how totally sudden the drop is. I have found that if I "train" myself to race through the place where it drops I'm likely to loose a few words but often can avoid dropping the call. Of course this is less than an "ideal" solution :)

  • SOLUTION - UPDATE: After carefully positioning Orbi Satellites using Wifi Alert as described above, I added SwiFi as recommended here. Since Orbi does allow for a Guest Network as well as the one SSID it creates, I added a Guest Network. Then Swifi had two networks to switch between. With careful adjustment of SwiFi I am now able to roam my house and Swifi switches between the main Orbi SSID and the Guest SSID. Although I'm notified that a network has been disconnected, the other network has already been connected and I have not lost a call since. – Madeline Gleich Aug 5 '17 at 22:22
0

Used wifi badger app, instead of "roamimg wifi fix" for same SSID with netgear Orbi. Seems ok so far, although it would disconnect and reconnect when I reach a set db from the router or satellite...

I found roamimg wifi fix disconnected for a longer period of time.

0

I have experienced the same problem and tried a lot to find the solution i have 2 routers one is DLink DIR 816 dual band and other is DLink DIR 803 , 816 is uses as repeater and is connected with my neighbor's router with whom I am getting internet and 803 is connected with 816 as an AP the solution i found is to match the security on both router 816 have option of automatic AES and TKIP but i set it to manual AES both SSID name and passwords are same i tried same thing with TPLINK WA801ND as access point I got same result. Even 816 is set to 802.11 b/g/n while 803 is set to 802.11 b/g but matching security works. The settings page screenshots are attached.enter image description hereenter image description here

0

If you have a Samsung Galaxy phone, you should have the Samsung app Routines installed. Create a new routine consisting of only the condition "wifi signal strength". Once this condition is selected and appears on the box, tap on it and choose the signal strength. It starts suggesting 40%. For me, the 50% worked best. Adjust this level on the slider. Next, under Actions, choose the following actions, in sequence: "Turn Wifi off"; and then add "Turn Wifi on". It worked flawlessly for me. Test it on the various rooms of your place, and if it does not works, adjust the signal strength level on the slider described above.

  • 1
    Where is this app sourced? I have a Galaxy phone and this app is not available on my phone, available through Google Play (the Routines app is really a task list manager), nor is it on the Galaxy Apps workspace that I can see. Is that AppName accurate? – wbogacz Oct 10 at 0:16
  • @wbogacz Looks like this is limited to Samsung Galaxy S10 or newer and/or Android 8.0 or newer – Andrew T. Oct 10 at 3:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.