0

enter image description hereI connected my Samsung Device(Android 4.1.2 ) for testing my app through the Android-ADT(Eclipse).

  • After closing the workspace when I tried to eject the device through Eject I get a dialog box saying the phone is currently being used please close any running software using the phone.

    Thereby forcing me to unplug the device manually.

  • Any help appreciated.

  • 2
    From command prompt try adb kill-server and then eject – samnaction Jun 30 '14 at 13:45
  • @Sameer it wonderfully worked by terminating the server from command prompt – user285oo6 Jul 2 '14 at 9:45
  • Okay I will make that as an answer – samnaction Jul 2 '14 at 10:51
2

From command prompt you can enter the following command

adb kill-server

and then try ejecting.

1

The dialog you mention is nothing to do with USB debugging: it's because the device's storage is mounted (via MTP or USB mass storage), and some app has a file open from that storage. It could be that you have a file manager window looking at the device's storage, or that your music player software is automatically indexing files on it, or something else.

To avoid the dialog, you need to find and close whatever software on your desktop computer has files from the phone open. On Linux you can use the lsof tool to help; on Windows you just have to guess.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.