I've been running CM11 on my Asus TF300t for a while now. A while ago, an (automatic) update broke my rom. From there on, matters have gotten worse. Right now, my tablet is a brick without an OS. Here's what I experience

  • No OS, tablet automatically boots into recovery.
  • Wrong recovery. Probably the Teamwin for the TF300Tg? It opens with 'Please enter password', and I can't access most of the features (E: Unable to find partition size for ... / E: Unable to mount ...). I've got a CM11 zip on my SD card, but I can't flash it. The recovery works, but most of the actions fail.
  • I cannot access FastBoot. If I press volume down + power, it just boots into recovery. Because of this, I can't flash the right recovery .blob.
  • A physical reset (with a paperclip) didn't change anything.

I'd be really grateful if anybody has anymore ideas / things I could try.

Thanks in advance

2 Answers 2


Autoupdates brick a lot of Transformers when on CM. Bad sounding situation, in my opinion. Fastboot and ADB are the only ways you could recover your device if you have a bad bootloader and recovery. Have you tried holding Vol-Down while resetting with a paperclip? That should force fastboot. If not, we can try adb.

Do you have adb access while your tablet is plugged in to your computer? Turn on your tablet so it is in recovery, and on your computer, run adb devices to see if your tablet is available. If so, adb -d reboot-bootloader should force your device to reboot into fastboot. From there, run fastboot erase x where x is:

system recovery userdata boot misc cache

and then after that, you can flash your files and/or restore your .blob files.

  • Thanks, here's two solutions I haven't tried yet and will try as soon as I get home. I recall adb devices working, so here's to hoping. Will report back if these are working.
    – Vic V
    Jul 2, 2014 at 7:50
  • It was a horribly scary process, but it looks like I've got the stock OS back. The trick was adb -d reboot-bootloader, followed by these instructions. I was beginning to give up on this tablet so I'm very grateful. Thanks again!
    – Vic V
    Jul 2, 2014 at 20:06
  • I'm glad the method worked for you!!! :D Jul 7, 2014 at 12:18

This is how i recovered mine sometime ago:

First you need to Download the correct .blob (Firmware) file from the Asus site here. When you downloaded the correct Firmware unzip it and remember its directory. Boot it into fastboot mode (when you press volume down on the little android it seems that the tablet is stuck but actually it is in fastboot mode) and then type:

fastboot erase system
fastboot erase recovery
fastboot erase userdata
fastboot erase boot
fastboot erase misc
fastboot erase cache
fastboot -i 0x0B05 flash system path/to/file.blob
fastboot -i 0x0B05 reboot
  • Cheers, but like I said, I can't access fastboot. There's no little android, alas. I just go straight to the faulty recovery. I'll try the other comment to see if that helps me getting into fastboot, then this.
    – Vic V
    Jul 2, 2014 at 7:49
  • 1
    When you are in recovery try to type adb reboot bootloader, that will get into fastboot hopefully
    – Matt
    Jul 2, 2014 at 7:55
  • 2
    This answer was 90% correct, but I'm awarding the bounty to IAmTheSquidward, since he answered first and provided the magic trick which appeared to be adb -d reboot-bootloader. Upvoting nonetheless. Thanks.
    – Vic V
    Jul 2, 2014 at 20:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .