1

In a 2012 thread about a case of OsmAnd being slow at rendering, one person advises this:

verify that you use Native Library (which definitely speed up rendering process)

And the replies seems to imply it works:

I selected the Native Library and deleted Ind.cache file. It has nearly doubled the rendering speed of my map.

I have the same problem of slow rendering, but I can't find the Native Library setting.

QUESTION: How to enable the Native Library in recent OsmAnd?

I am using OsmAnd~ 1.8.3 from F-Droid:

OsmAnd development preferences

2

To activate native rendering go into Settings/OsmAnd development/Use native rendering (Use C++ rendering instead of Java)

Edit: I've added a screenshot from OsmAnd+ 1.9.2g

Screenshot of OsmAnd+ 1.9.2g preferences

4
  • I don't seem to have this option, see screenshot. Nov 14 '14 at 5:07
  • Which version of OsmAnd are you using? Nov 15 '14 at 0:14
  • OsmAnd~ 1.8.3 from F-Droid Nov 15 '14 at 7:05
  • 1
    Installing 1.9.2g revealed that option. Nov 15 '14 at 7:15
1

OsmAnd 2.4.7 doesn't have "OsmAnd development" under Settings, but Settings / General / Safe mode (Java rather than native code) is off by default. Rendering is still slower than other OSM-based apps though.

Edit: the OpenGL flag on this version is under Plugins / OsmAnd Development / Settings / Use OpenGL Rendering. Still doesn't seem to help much though (on Sony Xperia Z Ultra running Android 4.4)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.