0

I am trying to connect my phone (archos 40 titanium) on my computer (W7 x64) using USB Debug mode (to make a backup). Here is what I've done:

  1. I've downloaded google SDK and extracted it in C:/adtbundle
  2. I ran SDK Manager.exe and enusured google USB driver was up to date
  3. I right clicked on Computer (in start menu) and I selected Devicesin the right panel of the new window.
  4. In other devices I select A40ti and right clicked, then Update driver.
  5. Then, I choose Browse my computer for driver software and then browse. I selected C:\adtbundle\sdk\extras\google\usb_driver.
  6. I get something like Windows can't found any drivers (I am translating since my system is in French).

When I run adb devices it shows an empty list.

How to install them and get adb working?

EDIT: Here are the new steps:

  1. I downloaded from here the driver, which I extracted in an new archosfolder next to google's like this:
    • C:/adtbundle/sdk/extras/
      • android/
      • archos/
        • amd64/
        • i386/
        • adb_winusb_driver.zip
        • android_winusb.inf
        • androidwinusb86.cat
        • androidwinusba64.cat
        • source.properties
      • google/
  2. Same as 3-5 but with path C:\adtbundle\sdk\extras\archos
  3. Same as 6
1

Google's USB Drivers are for the Google reference devices (Nexus series) only. You'll need to install Archos' drivers. They can be found on Archos' support page with instructions on how to install them and get ADB working.

  • Install the drivers
  • Add the vendor ID 0x0e79 to your adb_usb.ini, e.g. echo 0x0e79 >> "%USERPROFILE%\.android\adb_usb.ini"
  • Done!

Edit: The driver's from the support page didn't work, but these did. They came from an unreliable source and had other drivers from 2005 with them, but I stripped them and repacked. Feel free to verify with virus scanners.

  • Thank you very much. But I still get that message, please see edit – Vinz243 Jun 28 '14 at 10:41
  • Did you try unzipping the ADB driver package adb_winusb_driver.zip? – onik Jun 28 '14 at 10:55
  • Yeah, that's the files just next to it (android_winusb.inf...) – Vinz243 Jun 28 '14 at 10:56
  • Hmmm... If I remember correctly, my Android devices showed up as Android Debug Bridge even without the drivers when they were in ADB mode, are you sure you have it on in the phone? – onik Jun 28 '14 at 11:04
  • Yes, I think so, I've checked it and I can see it in my notification bar – Vinz243 Jun 28 '14 at 11:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.