0

I have SGH-M919 (SGS4 T-Mobile variant). First, it had stock ROM, stock firmware, and it was SIM locked to T-Mobile, so I unlocked it with SRS server service (I live outside the US, so labs in my area didn't have the tools to unlock it, since it's only a US variant. Also, other methods of unlocking did not work for me, unfortunately).

In the unlocking process I had to flash custom modem file with Odin (it was required for SRS to work). After the successful unlock, I flashed CWM and CM11, rooted the device with Kingo ROOT and everything worked fine except the GPS. It didn't work: no GPS satellites were found.

How can I solve this issue? Thanks.

I have already tried:

  • Reverting to stock firmware (by flash. Kies doesn't work). No only that it didn't fix it, the WiFi broke and couldn't be turned on. I has to recover everything with a recovery file I have made with CWM.

  • Installing stock ROM via the recovery. The GPS worked(ish), but was very slow. I then restored my CM setup with nandroid restore (again, via the recovery), and the GPS didn't work again.

  • While using the stock ROM, I tried to get to LbsTestMode in order to fix the GPS, as explained here, but I couldn't reach it - it just doesn't exist in Android 4.4.2 apparently.

0

With the helpful assistance from couple of people from XDA Developers forum I was able to fix the GPS.

I have found a modem file that was supposed to fix it in this XDA thread, and did everything by the instructions there.

All I had to do is download a .zip file that contains two modem files (MK2 modem) in it, and flash them in order with Odin. After that I checked the GPS with GPS status app and it locked onto a satellite blazing fast.

I noticed couple of hours later that suddenly the cellular signal was really weak in area that should have full coverage. So I flashed this modem (BN4) and it fixed it (and the GPS also fine).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.