0

I have Battery Doctor 4.9.3 installed on my Samsung Galaxy trend device with Android jellybean 4.1.2.

  • The problem with this app is that every time I try to update an app it starts initially and then later the download crashes.
  • Also there is What's app running parallel so just for few seconds I shift to chat and in the background I can see the app getting updated.
  • After just few seconds when I return to the play store the download fails for which I need to re-update the app every time (after 30% it again crashed and then later I again re-update).

In the app there Is an option for smart Saving which I have turned it on. Although the app works fine for saving the battery but it is interfering with Google Play to update or download the app while I move to another screen it is closing it after few seconds

  • 1
    Don't use "task killer" apps: in general, they have a negative effect on battery life. Here's why. – Dan Hulme Jul 1 '14 at 7:54
  • @DanHulme here's the link for you check the app it's not a task killer app as you have suggested .It will notify the user of any app running or hogging the CPU and the user has to kill or force close that app – user285oo6 Jul 1 '14 at 8:35
  • It lists under key features "Task Killer kills tasks with one click!" and "Kill apps when screen is off!" and the behaviour you describe sounds very much like it's killing Play Store when it's in the background. – Dan Hulme Jul 1 '14 at 8:52
  • I needed the app because it displays the exact time for my battery to drain and the amount of time required for a complete charge. Isn't is possible that by disable the Smart saving option I can avoid the store to stop the download – user285oo6 Jul 1 '14 at 8:55
  • 1
    Battery apps can be dodgily made, and if it has any task killing ability I'd just uninstall it to be honest. It's worth adding that the 'Battery Saving' these apps promise often works out worse than letting the OS handle it. They're a bad idea in general. – RossC Jul 1 '14 at 9:48
0

In the smart saving options I could de-select the auto kill apps on screen off option(i.e. When screen turns off the apps will be killed by default). After de-selecting the option now the apps are being updated smoothly as usual

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.