4

I have recently bought a MOTO E and it's working cool. Then I have enabled Developer options and changed my runtime from Dalvik to ART. Afterwards I restarted my device. I got the message saying Android is upgraging. After completeing the process I got exceptions like

unfortunately the process com.android.phone has stopped

Please help me how to get out of this problem. I am getting that message for around 10 times and mobile restarting once again.

  • As even system apps seem affected (com.android.phone is such), you probably cannot even utilize safe-mode for a remedy (though you might try). So unless somebody knows a trick to revert your runtime change by other means (e.g. via ADB), that probably only leaves a factory-reset. Hope you've made a good backup before changing to ART. – Izzy Jul 2 '14 at 8:56
  • Confirmed problem on Moto G 2014, phone froze when I attempted to turn the screen off. On reboot it is on 'Android is Upgrading' again but however has less apps to upgrade now, perhaps it might work. – AStopher Feb 12 '15 at 14:40
6

/data/property/persist.sys.dalvik.vm.lib contains the name of the runtime library you wish to use - libart.so or libdvm.so. So, you can switch back to Dalvik like so:

adb shell 'echo libdvm.so >/data/property/persist.sys.dalvik.vm.lib'

Source

  • thanx but i already did a factory reset – Software Sainath Jul 2 '14 at 10:11
  • Does this work on non-rooted phones? – AStopher Feb 12 '15 at 14:40
1

My friend had the exact same problem after switching to ART on his Moto E (unfortunately the process com.android.phone has stopped), and this worked for him:

  1. Power the phone off, then power it back on.
  2. If it gets stuck in a boot loop where it keeps going to the Android is upgrading... screen (possibly showing the wrong number of apps--for my friend it was showing 19 apps), hold down the power button until it turns off, then turn it back on.
  3. At this point it should go back to the Android is upgrading... screen, but this time it should show the correct number of apps, finish successfully, and the phone should work normally.
1

Erase userdata and reboot using fastboot. Resort to this method if you are ok loosing your data.

Installing Fastboot on your Desktop/Laptop .

Fastboot comes with android-sdk for windows. (make sure fastboot is installed)

Boot your phone in fastboot mode

Its generally done this way, press down volume key then power on button and hold them for 6-7 secs. You will see the notification light after which release the power on button and then the volume down key. wait for 3-4 secs. Fastboot screen will appear on the phone. Connect it to your host (via usb) and install the drivers.

Install fastboot drivers for your phone.

Open device manager in windows , you ll see something like 'fastboot condor'. rightclick->properties->(select Hardware Ids in details tab) you ll see something like

  • USB\VID_22B8&PID_2E80&REV_0100
  • USB\VID_22B8&PID_2E80

add the following lines in your android_winusb.inf based on the hardware IDs (android-sdk-windows\usb_driver_r03-windows\android_winusb.inf)

  • %SingleAdbInterface% = USB_Install, USB\VID_22B8&PID_2E80
  • %CompositeAdbInterface% = USB_Install, USB\VID_22B8&PID_2E80&REV_0100

update your drivers from android-sdk-windows\usb_driver_r03-windows\

check if your device is detected using the command

fastboot devices

in windows cmd

Erase user data

type

fastboot erase userdata

Reboot your phone

fastboot reboot

PS: I had a far worse problem. The phone just got stuck (in an infinite loop) with a dialog.

0

This will erase all data but if you had a Google account linked to your device, it will allow you to reinstall all Play Store apps you originally had.

You may also hold volume up and power button together and scroll to recovery mode using the volume buttons and then select it with the power button.

After getting in there scroll to wipe data / factory reset.

After it has completed, select Reboot now.

This should help.

-1

I know that this thread is old, but this may help others in the same situation. My mobile is a LG G2 Mini (D618) rooted with Kingo. After I changed it from Dalvik to ART, it took a long time to reboot, while optimizing all the apps. But then, when the UI showed up, I couldn't do anything because several error messages appeared in sequence. After a while touching OK for each message, the mobile would reboot and start it all over again. In fact it rebooted even if left alone.

I re-flashed it with the stock ROM (with the no-data-loss option) but nothing changed other than it becoming unrooted again. Also tried to access it with an ADB Shell but I kept getting an authorization error. Then, after rebooting it around 30 times, it reverted back to Dalvik by itself, and everything was fine again!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.