2

I have a Samsung Galaxy Y GT-S5360 which I have rooted. I have partitioned my 8GB class 10 SD card to have two partitions on it using AParted:

  1. A 2GB FAT32 secondary partition.
  2. The rest of the SD card into a primary partition.(FAT32)

The problem is, even after doing this and installing Link2SD and changing the install location to external, the apps are still being installed into the internal memory and I get a "low on internal memory" message every time I try installing new apps. When I check the Link2SD app list, many of the apps are showing that they have been already moved to the SD card and my secondary partition on the sd card is still pretty much empty.

What have I missed over here? (Sorry if this is a lame question. I'm new to rooting and stuff)

Link2SD showing apps moved to the SD cardStorage Info part1Storage Info part2

3

Note: Techicnally you probably couled use a FAT32 partition but I've had issues on several devices.

For Link2SD you need 2 partitions:

1) FAT32 this is your file storage, photos, media etc.

2) EXT3 (Or EXT2 or EXT4, but 3 has always worked for me) partition. This is the part this will be recognised as new 'internal memory'.

There is a full tutorial on XDA here and the keypoints are:

Next, create an ext2/ext3/ext4 partition (I suggest ext2 cause it works on all roms and kernels). This is where your apps will go. I suggest a value of 512Mb would be big enough.

Personally I use 1024 Mb.

Open Link2sd. You will be prompted to choose between ext2, ext3, ext4 and FAT32. Select the one you used.

It will say mount script created. Reboot your phone now

Go to Link2sd > Settings > Check the autolink (to automatically move apps upon installation)

To check your memory, select “Storage Info”. This will show you the current state of your internal memory, FAT32, and Ext# partition.

  • I tried formatting the sd card again to make the above changes. But now, only 1.9GB of the 8GB is showing up in the format menu(exactly the same as the second partition I made on it). Please help. – shyam Jul 3 '14 at 11:58
  • Just undo all of it, make the SD Care ONE SINGLE partition, let's say FAT32, ALL of it. Then create your 2 partitions, one FAT32, and one EXT3. Or use a PC app to do the partitioning. – RossC Jul 3 '14 at 12:02
  • I tried doing that but now that partition is "unallocated". I'm searching for a way to get it back. – shyam Jul 3 '14 at 12:16
  • If you don't know how to partition things, then be very careful with your device, this could brick it. Allocate ALL of it to ONE SINGLE partition, then repartition it after. – RossC Jul 3 '14 at 13:27
  • Yeah. I got that figured out. But this still didn't work. I'm sorry. Now I have created 2 partitions a) FAT32 and b)EXT3. But still when I try to download something new it says "not enough space". – shyam Jul 3 '14 at 15:52
0

Use mini tool partition (windows ) or gparted(linux) to create another partition . The file system must be ext4 . Then when u insert it . You will be asked to format. Format the SDCard . Now open link2sd

  • 1
    Could you provide the link for the programs? How to use any of them to create "another" partition? Please see How to Answer. – Firelord Sep 25 '15 at 13:51
  • Sorry for the inconvenience . My mobile does not support the latest version. So i cannot format or embed links in the answer. You can find the source in google. Thanks for your advice ! – Joe_Vj _95 Sep 27 '15 at 17:03

protected by Matthew Read Sep 28 '15 at 18:05

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.