About a month ago my application updates ate all of the memory of my phone (samsung galaxy young), so I decided to uninstall, or disable and downgrade applications. I did this to google play as well. Now I need to install an application so I need google play. I enabled it, but it writes a "no connection / retry" message.

  • I restarted the phone many times, it did not help.
  • I installed the google+ application, which can log in to my account successfully, so I think there is no problem with the credentials.
  • One of the applications wrote me, that I have to update google play, but clicking on that link lead to the same no connection message. It has currently the version 4.1.10 (I guess I purged all the updates when I disabled it).
  • I cleared the data and the cache of google play.
  • I checked the date & time settings, they are okay.
  • There is no Freedom application on the phone.
  • There is only localhost in the hosts file, nothing else.
  • I did not travel, I live in the EU, and try to access to the service from home.
  • I installed the google play 4.8.20 from here, and google play services 4.4.48 from here but there is no change.

I read about how to fix this error, but nothing worked for me so far, and I am sure I won't factory reset my phone... Any suggestions?

  • You wouldn't happen to reside in People's Republic of China?
    – bonob
    Jul 3, 2014 at 14:28
  • Nope, I live in Hungary.
    – inf3rno
    Jul 3, 2014 at 14:35
  • 2
    Ok, I just asked because China has cut access to Google Play about a month ago; I have been unable to update any app since then :)
    – bonob
    Jul 3, 2014 at 14:38

2 Answers 2


I feel your pain, this has happened to me. It's very frustrating. I tried clearing cache for apps, removing them using the application manager and a bunch of other unsuccessful attempts. The only thing that helped was a factory reset. Luckily I was able to backup my data prior to doing a full factory reset. I know you mentioned that it's something that you don't want to do. The only other option would be to root your device and flash your device with a new ROM - but doing this would essentially be a pseudo reset, so if this seems like a valid option, I would play it safe, backup and reset.

Also, you mentioned that you were able to read the host file? Do you see any specific URL's or IP addresses in the "hosts" file? If so, you want to clear anything that says Google play. Leave only the first two lines - which should be something like:    localhost

Where x is variable and :port would be defined

I found a thread on XDA forums that might help - but it requires Root.

Tested FIX for Google Play Connection Error

Let me know if this helps.

  • Installing all applications again, clicking on updates for an hour, set the passwords, register the device again, etc... is a pain in the ass, so it can be only a last resort. Btw. I read that even factory reset did not help for somebody by this error. I'll wait for other answers, maybe... :S
    – inf3rno
    Jul 3, 2014 at 14:34
  • I updated my answer for you. Hope that helps.
    – Dark_Cyber
    Jul 3, 2014 at 14:39
  • Nope, as I wrote, there is only localhost in the hosts file, nothing else.
    – inf3rno
    Jul 3, 2014 at 14:42
  • Maybe there is no support for google play 4.x versions anymore, that's why it cannot update itself, but I think that is unlike by a worldwide service.
    – inf3rno
    Jul 3, 2014 at 14:44
  • No, that can't be. There are millions of Android users and a large portion are still running Android Froyo, lol.
    – Dark_Cyber
    Jul 3, 2014 at 14:47

I was also struggling to get an old HTC Flyer tablet, running a Honey Comb ROM (LeeDroid v4.3.0), to connect to Google Play after a factory reset. I tried many many things, but this was what resolved the issue:

  1. Downloaded and installed the latest version of both Google Play Services and Google Play Store available for Honey Comb, which as of today (Jan 27, 2016) was:

    • Google Play Services 8.4.89 which I downloaded from this link

    • Google Play Store 6.1.12 which I downloaded from this link

Then, I followed these steps to install them:

  1. Force stopped the installed Google Play Store I had on my tablet (4.8.20), cleared cache, cleared data, etc.

  2. Installed Google Play Services

  3. Installed Google Play Store and DID NOT open it.

  4. Reboot

  5. After reboot, everything ran smoothly.

I hope this can help someone else, because it took me some time to overcome this error!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .