1

I have been receiving about 50 flash SMS a day, with my service provider name, from the number 50. As I read here, it might be a issue with activating and deactivating cell broadcast on the phone. However, I could not find the path suggested for the deactivation (Setting - Call - Other Call Settings). The option does not exist on this path. Any help?

Mobile: HTC Desire 816

Android Version: 4.4.2 with Sense 6.0

  • Welcome to Android Enthusiasts! There are just 15 questions using the cell-broadcast tag, most of them asking how to turn it off, several for HTC devices. Have you checked them? With some luck, one of the variants works for you. If so, be welcome to answer your own question – otherwise, please edit it to indicate what you've tried and where you're stuck. Thanks! – Izzy Jul 4 '14 at 15:29
2

Try this

Settings - Call - Slot 1 call settings - GSM call settings - Cell Broadcast

  • Its working fine... No Flash sms after unchecking cell broadcast. :-) – DCP Feb 20 '15 at 20:21
1
  1. Open menu and select call
  2. Open the call setting and select SIM 1 or 2 setting
  3. Open GSM call setting
  4. Uncheck cell broadcast options

Your problem is solved.

-1

Remove your SIM and put it into any Nokia phone then go to Setting>Phone Setting>Cell info Display>Off.

Then put the SIM back in your HTC Desire 816.

I used Nokia X2-01 for this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.