6

YouTube app says "Connection to server Lost/ Tap to retry" When a video is played. The same bug presented itself on 3 different devices with the youtube app version(5.7.38) as the only common feature.

Samsung Galaxy S Duos|JB 4.2.1 Micromax Canvas HD|JB 4.2.1 Asus Nexus 7|KK 4.4.4

Rest of the features are working so its not a network problem. Even YouTube ads play, but not the videos.

The problem is same on both WiFi and Data

Similar questions have been asked before but the troubleshooting methods DO NOT work. Any help woild be appreciated.

  • It would help to know which troubleshooting steps you've already tried. – Chahk Jul 8 '14 at 14:15
1

Clear cache and data of YouTube and Google play services. It is recommended to do this provided you have a high speed WiFi/data access. These apps may download approximately 70-80 MB after clearing their data.

Steps:

  • Disconnect all data connectivity. i.e. WiFi & mobile data.
  • Go to your phone's 'Settings'.
  • Click on 'Apps'.
  • Scroll down to YouTube and click on it.
  • Click on following buttons in order: 'Force Stop' > 'Clear Cache' > 'Clear Data'.
  • Press 'back' button to come back to application list.
  • Scroll up for 'Google Play services'.
  • Do same again in order: 'Force Stop' > 'Clear Cache' > 'Clear Data'.
  • Restart your device.
  • Switch on your data connectivity. i.e. WiFi/Mobile data.
  • Open Play Store and wait until everything successfully loads up.
  • Now exit from Play Store and open up your YouTube app. It should probably work fine now.
0

Follow these simple steps to make sure whether the problem lies with your video or the application-

  1. Try to update the App from the Play Store if available.
  2. After the update power off your device and wait for few minutes.(2-3 minutes max)
  3. Power on your device and open your app and check for any other video is it able to play or not(from the start till the end).
  4. If the video is able to play then the problem lies with your video which you are trying to view as it might be blocked or censored in your Country.

  5. If most of the videos are not playing and showing the same error then you need to have a follow up with the You Tube support team with the video link and the device specifications.

  • I trie uninstalling updates and updated the app again. Tried many different videos. Doesnt work, unfortunately. – KnIn Jul 8 '14 at 6:48
  • @KnIn then you need to do the last step – user285oo6 Jul 8 '14 at 6:50
0

I faced this bug when my YouTube app was outdated. Try to update your YouTube app and/or Google Play Services to the latest version, as YouTube depends on it.

protected by Community Oct 9 '14 at 16:46

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.