0

When my phone is locked and the screen is off, I could usually wake it up only by pressing the home or power buttons.

Now, the screen also wakes when I press a volume button.

This started happening for no reason that I remember, and is extremely annoying since I use the volume buttons for controlling audio while the phone's screen is off (an option in Apollo).

Now when the screen goes on, the volume buttons have stopped changing the songs, but instead just increase the volume - which is quite a traumatic experience when you're trying to change a song on the go.

It also results in my phone's screen being on most of the time because I like to change the volume a lot.

How can I disable this?

Running:

  • Android: 4.2.2
  • CyanogenMod: 10.1.3
  • Is this stock ROM? What Android version? – geffchang Jul 8 '14 at 8:46
  • @geffchang edited – jcora Jul 8 '14 at 8:50
2
+50

Some versions of CyanogenMod have the “Volume rocker” option in Settings → Display; if this option is selected, volume buttons will wake up the phone.

There are also other ways to get this behavior (e.g., the GravityBox module for Xposed has the “Volume rocker wake” option in the “Navigation keys actions” screen).

  • Well that was easy... Should've found it myself, thanks. – jcora Aug 3 '14 at 13:15
  • @jco Please close the bounty... – Keshava GN Aug 4 '14 at 7:54
  • @KeshavaGN It doesn't let you close immediately so I left it, and it would be automatically awarded to this answer anyway. But yeah, I did now. – jcora Aug 4 '14 at 14:34
0

check your device for unwanted applications. And also check your device administrator. Remove any unwanted application from it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.