0

I have a 3g USB stick modem, connected to my Windows 7 laptop. I am sharing the internet connection using hostednetwork (Windows 7 facility to turn a laptop's wifi into an Access Point). Now... it works. Mostly.

My girlfriends iphone connects and works fine all the time. Her laptop connects and works fine all the time as well. An android phone (XPeria Z) I have connects all the time, wi-fi stays connected but network connection (not just internet) is very flaky. Sometimes it drops in 5 seconds, then at some stage it comes back again in a couple of minutes, then drops again and so it continues. Sometimes it may even stay working for 15 minutes but not often, most of the time it lasts a minute or two. I can reconnect wi-fi and get another minute or two of internet or just wait until it starts working again (also for a minute or two)

It's not just internet that is not working. I used a ping utility on the phone and when it can't connect to internet it can't even ping the host laptop.

I compared the wifi settings on the iphone with the android phone, they are the same. It's not the problem with the default gateway settings, because it does work from time to time and because, when it doesn't work, pinging the default gateway (laptop ip address) doesn't work either. For the same reason it's not a dns or other TCP/IP settings problem. It's also a quiet place around here and there's no other wi-fi networks around either. The problem happens with or without other devices connected to wifi.

The only thing that seems to make it work for longer is constantly using the internet. Well I am not entirely sure about that but that's what it feels like. If you keep it loaded non-stop sometimes you can get it to work for like 15 minutes.

Any ideas what I could try, how I can diagnose the problem? It's extremely annoying.

  • Does the same phone work normally on other Wi-Fi networks? – Dan Hulme Jul 12 '14 at 8:46
  • Yes, absolutely no problems. – Leo Jul 12 '14 at 8:47
0

If you have "Avoid poor connections" enabled in your Xperia's wifi settings, try turning it off:

Settings > WiFi > Advanced > Avoid poor connections
  • 1
    Good idea, haven't looked there. But Avoid poor connections was off already. Thanks anyway! – Leo Jul 19 '14 at 10:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.