0

I'm trying to root my phone (with a view to putting DebianKit onto it), and have had several attempts, each time getting a little further before stopping to look more stuff up. But now I seem to have gone back a step; in the past, "adb devices" has worked (with the phone displaying the fastboot screen), and I've been able to use "adb backup", but now, "adb devices" doesn't find anything, and "adb backup" can't see anything to backup from, when in the fastboot state. However, to my surprise, when the phone is running normally (i.e. Android is fully running --- I hadn't tried adb with it running before), "adb devices" does see the phone, and "adb backup" asks me to unlock the phone. There's no screen lock set, so it can't be referring to that. "fastboot devices" can see the device just fine.

The change I suspect is that I set the phone up to talk to my employer's outlook/exchange server, and their security arrangements require the phone to have the PIN lock. I've removed that account from my accounts list, so I could turn the PIN lock off for my next attempt at rooting; however, at the top of the fastboot screen, the first line says "*** LOCKED ***" in white on a purple background, and I don't remember that being there before.

What I really want to do at this stage is ideally take a backup, or at least get my photos copied from the phone; I do have Dropbox, and can presumably ship the photos out via that if I have to; and then could do a factory reset; but I like to understand things, and would rather know what is stopping the device showing on adb, and what this LOCKED state is.

Device info: HTC One M8, and I'm accessing it from Debian Wheezy (with ratpoison window manager, so there's no Gnome to get in the way). I'm using a motherboard USB 2.0 connection, so it's not the known problem with USB 3.0; and it has worked on that USB connection before.

  • Having looked again at a screenshot in some of the instructions I found, it appears that the LOCKED message was probably already there. – HillWithSmallFields Jul 12 '14 at 16:00
0

You need to unlock your bootloader. You'll need to go to the HTC dev website and select your device in the menu on the right, and then follow the instructions it gives you. (Note that this might void your warranty)

  • Thanks, but the problem is that I'm trying to take a backup in preparation for unlocking the bootloader; I understand that when I do unlock it, my device memory will be wiped. Also, it doesn't fit with the fact that I was able to take backups using adb previously, but can't now. However, looking back at the instructions I found, it seems that the LOCKED message was probably already there. – HillWithSmallFields Jul 12 '14 at 15:57
  • Is USB debugging enabled? Follow the steps here to enable it. – keepcalm Jul 13 '14 at 0:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.