5

I just 'upgraded' from the Samsung Galaxy S4 to the S5. Both use similar Android 4.4.2 Touchwiz software, but the new one has some odd behavior. I set smart screen sleep (or timeout, how it's called) to on and put it to one minute. I do have the Developer Options revealed, but the "Stay awake" is not checked.

I'll describe some situations:

  • Phone unplugged, unlocked -> Sleeps after 1 minute idle.
  • Phone unplugged, locked -> Sleeps after 1 minute (or even less) idle, no matter if I have notifications or no.
  • Phone plugged in, unlocked -> Sleeps after 1 minute idle.
  • Phone plugged in, locked, manually woken up (pressing some button) -> Sleeps after one minute.
  • Phone plugged in, locked, woken up by some notification -> Rings, displays the notification, and never sleeps until I press the lock / power button.

I tried to minimize the problem by minimizing the notifications I get while it sleeps: turned off WiFi, blocked messages, etc. But there is still one problem. I charge my phone overnight. Plug it in at evening (22:00), at about 1:00 (night) it finishes charging. The "Battery full" notification appears, and also the popup saying "Close the charging cover for water protection" fires up. And after that, the phone does not timeout. And when I wake up, the phone is very hot. I bet it's not OK. And also, from my knowledge, static images burn into OLED displays. I really don't wanna break my phone by charging it at night.

What I have tried:

  • Restoring and leaving developer mode off.
  • Resetting to factory, twice.
  • Tried letting it on silent with and without vibrate.
  • Tried putting some apps to block notifications.
  • Tried changing all the power, timeout and sensors options.

Nothing stops it from lighting up and never lighting down at night, and overheating itself. Any ideas?

  • AFAIK this is a 'feature' of the new Samsung bootloader. There's no work around outside of modified kernels etc and even then nearly all, if not all, custom ROMS have similar issues. It's worth noting that leaving it plugged in all night isn't great for the battery whether on or off. – RossC Jul 14 '14 at 7:59
  • A custom ROM would make me loose all the cool sensors and features, so.. Nope for now. But I found a workaround, see my answer. – Bodo Jul 14 '14 at 9:26
  • Cool, but you don't necessarily lose them if you have the Touchwiz framework in place in the ROM, obvioiusly with CM and AOSP you will. But I never use them, and the speed difference is enough for me to never, ever use TW again. BUT as with all these things it's user preference! – RossC Jul 14 '14 at 9:41
  • Wow, do you know any roms that are based on tw framework? I'd be interested in trying custom firmwares, without loosing the fingerprint sensor and the gestures. Anyway, for now I'll stick with the (towel) root'd kk stock, but a custom fw that keeps the sensors would be dead cool for the future. xD I had CM on my GS4 and it was a major speedup, but sacrificed the gestures. I don't wanna loose them on this one cause' they're pretty cool. – Bodo Jul 14 '14 at 9:57
  • forum.xda-developers.com/galaxy-s5 Under 'development' (most ROMs) and 'Original Development' which is more 'from scratch or specific code written by devs'. Full of ROMs! – RossC Jul 14 '14 at 10:05
3

I had the same problem and today I did find what was causing my problem.

It just started yesterday, 2 weeks after I got the phone. And the ONLY thing that was different is that I started using a generic AC charger that arrived yesterday.

When I suspected it was the charger this morning, I switched back to the white Samsung charger that came with the phone - and when the battery was fully charged, there was no 'beep', just a notice on the notification list. Screen did not light up. So I suspect that the generic charger I had just received was overcharging the battery, and the phone must be designed not only to do an audible alert, but to keep repeating that audible and screen-on alert until the phone is unplugged.

I have the phone charging on the white cable/plug that came with it, and I have a spare for travel. That's the charger I used up until yesterday - and never had a problem. So I think this resolved my problem with the Battery Full alert - and I will update again if it turns out that my problem is not fixed.

  • Wow i am also using a generic AC adapter, never tought it might be the problem. Currently solved by installing a TW based custom rom. (xTreStoLite) Thanks. – Bodo Aug 25 '14 at 20:25
3

I am answering my own question, because i somehow solved it. I downloaded the Battery Doctor app (the one featured by Clean Master) and created a scheduled profile for night that has timeout set to 5. Also enabled 'charging screensaver'. It's ok now. Battery doctor takes over the TouchWiz uselsss popups and notifications, and forces it to stand by after 5 secs. It's all OK now :).

This is the app I am using: https://play.google.com/store/apps/details?id=com.ijinshan.kbatterydoctor_en&hl=en

  • Excellent, you should accept your answer, but I'd recommend a quick edit to add in a link to the app you are using! This will no doubt help others! – RossC Jul 14 '14 at 11:24
  • 1
    OK, I add the link now. I tried accepting my own answer, but it forces me to wait 9 hours from posting time (7 hours from now on). – Bodo Jul 14 '14 at 11:25
1

I just had this problem too. The solution without having to download any outside apps is to go to "developer options" then uncheck "stay awake while charging" Not sure why they would have this as a default setting...

protected by Community Feb 13 '15 at 16:01

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.