4

I'm between jobs and, as a result, no longer want Google Now to keep telling me when I should leave for work, how long it will take me to travel there and that I'm running late.

I can remove my work location from Google Maps by logging into it on my desktop PC and selecting Settings → My Places.

enter image description here

However when I start Google Now and then select Magic Wand → Places it still shows me a location for my work. I can select it and erase the address, but I am unable to get it to accept nothing as a location.

enter image description here

Is there any way I can tell Google Now that I no longer have a work location?

So far I've tried:

  1. Clearing the Google Search app data and cache but my incorrect work setting still remains.
  2. Telling it that I no longer wanted to be notified about getting to work but it applied that setting to all my calendar appointments and I stopped getting any notifications for anything in my diary.
  3. Setting my work location to the same as my home. I still get notifications for going to work, except that they now happen at 9am and tell me that it'll take me 0 minutes to get there.
  4. Launching Google Maps on my phone, pressing the user icon (next to the directions button to the right of the search field), tapping and holding Work, clearing the field and submitting it. Although Google Maps now says Enter work address (implying that the field is empty) this change isn't reflected in Google Now as it still shows my work address.

Anything else I can do?

1

Thanks to a pointer from Pam, I waded through a number of potential solutions until I found one that seems to work:

[update] Although the steps appear to work, less than 24 hours later Google Now will automatically re-add your work address - even though you've not got it listed in Google Maps.

  1. From Google Now home screen tap your "menu" button to open the settings (for my Galaxy S3 its the far lower left button.)
  2. Tap "Settings" and then turn Google Now to "Off."
  3. A confirmation box appears. Check the button that says "Also turn off Location History."
  4. Click "Turn Off."
  5. At the next screen, click "Turn On"
  6. Click "Yes, I'm in."
  7. Your "home" address should show as your current GPS location.
  8. Scroll down until you see a "magic wand" symbol in the lower right corner and tap it.
  9. Click "Places" (it should show a #1 next to it.)
  10. Your Home address should appear (you can tap to edit this if not correct) and "Work" should be empty.

enter image description here

You will have to re-enter any other personal settings but at least you can now edit your "work" location (or just leave it blank)

  • Less than 24 hours later and Google Now has "helpfully" re-instated my work location. The steps above may work for a short while, but they don't last. – Richard Jul 16 '14 at 12:38

protected by Community Dec 11 '14 at 17:21

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.