1

I downloaded the Android SDK bundle for Linux because I want to start making some apps, but I've run into a couple of problems here. When I tried to create an emulator through the AVD Manager, and I tried to run it, I got the following error message:

Starting emulator for AVD 'AVDTEST'
Failed to start emulator: Cannot run program "/home/luke/adt-bundle-linux-x86_64-20140702/sdk//tools/emulator": java.io.IOException: error=2, No such file or directory

If you look, you will see that there is an extra slash before the tools directory, so I'm asking if anyone knows where I can go to change that path.

I tried running the emulator explicitly from the command line, but, even though I can clearly see that the file is there, and I am now providing the correct path, I still get the no such file/dir error.

0

1 Answer 1

0

Change the SDK directory path from Eclipse settings to the root of your SDK path. Also, chmod the files to executables.

7
  • 1. I can not find a settings option in eclipse, that's why I asked this question.
    – Luke
    Commented Jul 13, 2014 at 19:10
  • 2. In the SDK manager, the ADK path is already displayed as: /home/luke/adt-bundle-linux-x86_64-20140702/sdk
    – Luke
    Commented Jul 13, 2014 at 19:11
  • Window -> Preferences -> Android and browse to the SDK folder. Update sdk and the Eclipse ide if it still doesn't work. Commented Jul 13, 2014 at 19:11
  • Thanks, but like I said, the Path to sdk is correct, its that extra slash that is messing things up, I'm wondering where I can go to change that specific path (i'm checking for updates now, although everything should be the latest version, because i just downloaded them both today)
    – Luke
    Commented Jul 13, 2014 at 19:22
  • yeah no updates to perform
    – Luke
    Commented Jul 13, 2014 at 19:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .