1

In my WI-FI list, I see 5 password protected WI-FI networks that appear to be in range. The problem is, I know these networks are not in range. It appears as if I was in range at some point and when I got out of range they did not go away. They show as available at home, at work(20 minutes from home), at the cottage(2 hours north of here) and anywhere else that I go.

I have never connected to these and I do not know the password to any of them. If I press and hold on them, the only option I have is "Connect to a network" so I cannot "Forget" them as I was never connected in the first place.

What could have caused these to start appearing in the list? Is there a way to get these out of my available "WI-FI Networks" list?

  • Do you have root access on your device? While I cannot answer the "why", I might be able to show a way to make them "go away" then. – Izzy Jul 14 '14 at 16:02
  • I do not have root access on my device. – liebs19 Jul 14 '14 at 16:16
  • A pity. With root, you could use a "scalpel" to solve that (editing a single file – /data/system/misc/wifi/wpa_supplicant, if I remember the path correctly). Without root, just "atomics" for all I know (i.e. a factory-reset would cure it; I don't know of any way to edit/reset the wpa_supplicant without root apart from that). – Izzy Jul 14 '14 at 16:20
  • So the file wpa_supplicant is supposed to hold the wi-fi networks that are currently in range? – liebs19 Jul 14 '14 at 16:49
  • 1
    Looks like I've missed that part of your question. All networks you've connected to in the past are stored in a file called /data/misc/wifi/wpa_supplicant.conf (I've just checked the location again). Those you've not been connected to are not saved to that file. No idea where those are stuck – but I've had a similar case with one of my devices as well in the past. I don't remember how I've got rid of them; but you could try switching to airplane mode for a few seconds, that might trigger some "purge". – Izzy Jul 14 '14 at 20:48
2

While all networks you've connected to in the past are stored in a file called /data/misc/wifi/wpa_supplicant.conf, networks "just seen" around (but never connected to) are IMHO not stored to any file, but just "cached" in memory. So a simple trick to get rid of them is to enter for a couple of seconds (or a minute if seconds are not enough). With WiFi being disabled, the system should see no reason to "stick" to that "cached" information, and thus "forget" the unknown networks. As soon as you return from airplane mode, it would need to "rebuild" its cache again – but those "stickies" should be gone for good (until next time, maybe, but then simply repeat the action).

  • 1
    This worked great. I only needed to leave it on for a few seconds. Thanks for the help! – liebs19 Jul 15 '14 at 14:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.