2

I turned off my wifi connection and noticed a heavy impact on my battery life. In a few hours without any usage, it dropped more than the whole day before.

See the drop at end while wifi (WLAN) was disabled:

There are many issues where battery life is reduced when wifi is turned on but not when turned off. What could cause this and how can I fix this? Could it be using some mobile data connection that drains the battery more than wifi or is it a device problem?

While wifi was on, it was actually connected to a network. There is no increase in mobile data usage. No suspicious increase for battery consumption for any particular app. Top consuming apps are:

  • idle 40%
  • display 19%
  • mobile standby 18%
  • android os 13%
  • wifi 6%
  • google services %4
  • android system 2%

Update: It looks like it's constantly switching between E, 3G, H and H+ every few minutes, even without moving the phone. In 2G mode the connection seems to be stable and the battery loss is gone.

  • 1
    A shaky 3g connection in poor coverage could do that is guess. – RossC Jul 17 '14 at 8:25
  • @RossC Do you know any any way to detect shaky connections? The icon always shows 3/4 or full EDGE coverage , sometimes 2/4 HSDPA. I live in a big city and I think I can see a cell base station right across the street (I did the whole test showed in the image at home). – kapex Jul 17 '14 at 11:07
  • If anyone has a guess why the question was downvoted or has any suggestion for improvement please tell me. I'm going to test it with 2G only option enabled now. – kapex Jul 17 '14 at 11:09
  • 1
    If your phone is constantly switching between 3G (HSPA) and 2G (EDGE), it's possible that the connection is unstable and your phone is continuously searching for (better) signal. This could definitely cause the battery to drain quicker than it you had a stable connection. 2G-only mode will probably resolve this. If your phone is rooted, you can automate the setting (via Tasker or Llama for example) whenever you are in that particular location. – Chahk Jul 17 '14 at 13:04
0

Activating the 2G only option solved the issue, indicating a problem with the connection, as mentioned in the comments.

Another thing that solved it (temporarily, until I install more apps I guess) was reinstalling the OS. I only installed few apps and the minimal PA Gapps package (contains only some indispensable apps by Google), which presumably reduced the amount of background data send. Overall battery consumption with 3G enabled is way lower than with only 2G before.

I've also updated the radio firmware, though I can't confirm if it had any effect. It still seems to switch a lot between E, 3G, H and H+ but without any actual data traffic there is no noticeable impact on battery life.

Another suggestion I've found online somewhere is to use an app that switches to 3G only when particular apps like the browser is used and switches back to 2G otherwise.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.