28

I have a smart tv (pilot) which run android 4.0.2 . I connected it an external keyboard (through USB). I have English and Hebrew in the keyboard. The problem is that I cannot switch language through "alt+shift" . In the android keyboard I can switch through the GUI in the tv , but not through the external keyboard. What can I do ?

Thanks! Tom.

1
  • 1
    For me on the Rii i8 the "win" + space combination worked
    – SatA
    Apr 2, 2018 at 9:22

5 Answers 5

26

What you have to do is pair your external keyboard then

  1. Go to Settings -> Language & Input -> Physical Keyboard
  2. Then tap on your keyboard and a dialog for choosing the keyboard layout should appear.
  3. Choose the layouts you want (note that you have to select two or more to be able to switch) and then press back.

Near the bottom of the dialog a label saying "To switch, press _____ " which, in my case, is

CTRL + SPACE

Hope this helps!

4
  • 1
    Do note that simply pressing Ctrl-Space does not work out of the box. Even though the soft keyboard might have multiple languages configured, the external keyboard must have them configured separately on Android 5.0+.
    – dotancohen
    May 27, 2017 at 12:34
  • Not related to the question.
    – Rambalac
    Dec 4, 2017 at 7:31
  • On Android 11, I found this setting under "General Management", then I tapped on "Physical Keyboard" and was able to change the language to Dvorak. Dec 26, 2021 at 1:05
  • @SurpriseDog oh, I did not find such a menu in my Android TV 10. Only language of virtual keyboard can be changed. USB keyboard is set to US English and it does not work with my keyboard.
    – jarno
    Feb 19 at 11:19
7

I found it switches by using Shift + Space.

1
  • The little help dialog thing said “search+space” to switch. I noticed this didn’t work, but then I would accidentally switch the layout in my normal typing. Turns out this is the shortcut that was doing that! Thanks!
    – binki
    Oct 2, 2020 at 17:03
5

Go to Settings -> Language & Input -> Physical Keyboard

On the LG G3 (D855) this menu item is not exist.

LG G3 + Logitech keyboard (Android 4.4.2) shift + space

2

Press Shift + Ctrl + Space

Or

Press Alt+ Ctrl + Space

1
  • 1
    Not sure why you got -2. This is the only thing that worked for me! Thanks!!! Oct 17, 2016 at 10:26
1

Plug your keyboard in, go to SettingLanguage & Input settingsKeyboards and Input MethodsYour USB keyboard. Change the Language.

If not listed, this means you have problem with your android. I have changed it that way.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .