3

This question already has an answer here:

I just decided to move from Windows to Linux for my Android development, I just finished to setup Android Studio, I was able to import my project into it, but now I want to be able to run my application on my Google Nexus 5.

In my Android Device Monitor, my phone is detected as unauthorized.

I put :

SUBSYSTEM=="usb", ATTR{18d1}=="0bb4", MODE="0666", GROUP="plugdev"

Into :

~/.android/adb_usb.ini

marked as duplicate by bmdixon, ale, Izzy, Dan Hulme, Chahk Jul 21 '14 at 14:14

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • You can find your answer here: Configuring ADB for Nexus 4 on Ubuntu 11.10. Little different device, so you might have to replace some values – but close enough to solve your issue :) – Izzy Jul 19 '14 at 21:42
  • That question is not the same as the other. Swann's problem is that he didn't authorized the host to access the device via adb (as answered by keepcalm). – Flow Jul 20 '14 at 17:26
3

You need to enable USB debugging on your phone. You should get prompted to accept an RSA key, which will mean that your computer is authorised.

Also keep in mind that any coding questions belong on StackOverflow.

Not the answer you're looking for? Browse other questions tagged or ask your own question.