0

I have Goophone i5c (iPhone 5C clone, MTK6572 chipset, non-removable battery), and I'm trying to upgrade my Android.

I have installed:

  • Smart Phone Flash Tool
  • adb-setup.exe
  • MT65xx USB VCOM drivers

I still can't upgrade my Android. Most guides require to remove the battery, and I can't remove my battery as it's stick like the original iPhone battery. I also watched this video on YouTube and tried it and nothing happens, it's still stuck on detecting COM port.

SPFT stuck on detecting COM port

As per checking my adb devices, it seems my device is detected.

result of adb devices

2

I'll be answering my question.

I downloaded USBDeview and I deleted all COM ports that are open. I also did removing my USB controllers on my Device Manager. I restarted my computer to reload all the drivers; then opening the flasher generates a new COM port, clicking the upgrade and it worked.

0

Have you checked that your ADB drivers are working.

Just run following command from where you have installed ADB

adb devices

If not detected try manually updating your phone ADB drivers. Install generic drivers here. link

If not try the following Post 1 #Troubleshooting part

Once you are sure that ADB is working...

Follow steps given in this Post 1

  • I'd pdanet on my local, I did update to my post and my device is detectable. What do you mean flashing is a breeze? – daison12006013 Jul 19 '14 at 1:14
  • The only things resulting in error in flashing is "driver error" and "wrong files" – user52093 Jul 19 '14 at 8:11
  • Check the updated link.. – user52093 Jul 19 '14 at 8:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.