We recently bought a used Toyota Prius that has Bluetooth installed with the JBL audio system. Whenever my phone (stock Nexus 4 running 4.4.4) connects to it, the car sends a "play" command that automatically starts the most recently used music app (Google Play Music, Pandora, etc.). It doesn't matter if no music app was open on the phone, the command opens it up and it starts playing no matter what, and there's no way on the car to stop it from sending the command, as mentioned here. Is there a way to stop this from happening?

  • Interestingly, I have the opposite experience. When a bluetooth device is connected, the Android device always loads the factory Music app, and not the most recently used music app. I would prefer it to load the most recently used music app. Commented Jan 10, 2016 at 21:59
  • Unable to post as an answer, but a simple solution uses the (free) Automate app from LlamaLab together with a very simple script (Prevent Bluetooth Autoplay). Commented May 29, 2019 at 21:04
  • @FosterBoondoggle Hi, it's been a while. This question has been unprotected, so perhaps you want to convert your comment as a proper answer? :)
    – Andrew T.
    Commented May 12, 2023 at 7:45

3 Answers 3


There's a Bluetooth connect & Play app that can intercept the incoming "play" command. While it was originally designed to let you start a specific music app playing when a specific Bluetooth device connects, you can instead select "STOP music from playing" to keep any app from starting when the car connects.

  • Sounded promising but didn't work for me. Combination of OnePlus One (Marshmallow) and audio system of Renault.
    – Dror
    Commented May 9, 2016 at 19:39
  • This has worked for me for both Android 8.0 and 9.0. Just need to remember you have it installed if you need to change the settings... :)
    – LightCC
    Commented Aug 31, 2018 at 20:16
  • Does not work for me either. I can't believe such a simple thing isn't a default setting in the bloody phone... Commented Aug 14, 2023 at 4:22

Go to Settings, Applications, Application Manager, and then Modify System Settings. Find the player that is starting (for me it's Samsung Music) and switch the toggle to OFF.

  • 4
    This is what I was looking for, but it's not correct on Android 8.1.0. Wherever they moved this setting to (could they please stop moving things all the time and invalidating answers on the internet?), I cannot find it (I have used it in the past...).
    – LightCC
    Commented Jun 15, 2018 at 18:14
  • 1
    In current Android versions, you can search in settings to find this (i.e. "Modify system settings").
    – LightCC
    Commented Aug 31, 2018 at 20:01
  • It dosn't work like this any more. I find non of my music player apps (that open a player notification on bt connection) in the list.
    – ssssaaaa
    Commented Feb 28, 2023 at 11:37

Another work around if other method fail, if the android phone always use the same music player to autoplay when bluetooth is connected. Just create a silent mp3 file and rename it AAA.mp3, this will ensure it will be the top of the file list. make it like 5 minutes or 1 hour, whatever you want. file size will be bigger though.

In my case, it will always use the default music player to autoplay. So i just put only that silent mp3 in the playlist. It will still autoplay, but a silent audio. Then I just turn on my favourite music player or podcast.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .