I'm following the instructions at http://htc-one.wonderhowto.com/how-to/unlock-bootloader-root-your-htc-one-m8-0154444/ and have found a stage where I don't have enough information, which is at Step 9 in the instructions, which says "Start by grabbing SuperSU from Chainfire directly on your phone, or download and place the file in your device's "Download" directory."

I tried doing it directly on the phone, but that didn't install it properly --- it seemed to want the phone already rooted, but I'm doing this as a stage of rooting the phone. When I then try running supersu, it complains it can't find the su program.

So now I'd like to "place the file in the Download directory", which presumably means using "adb push", but I can't find where I should be putting it, i.e. any directory called "Downloads" or anything like that. I've looked around, using "ls" in the adb shell, and I suspect it might be in /data, but I can't look in there (perhaps because the device isn't rooted yet?) The instructions expect the supersu zip file to be unpacked by the TWRP recovery, which I have installed.

http://androidadvices.com/root-install-custom-recovery-twrp-image-htc-m8-android-phone-guide has alternative instructions, which just say to put it in "a suitable location"; could I, for example, just dump it in "/" ?

2 Answers 2


Download the zip to your computer, boot up the phone in normal mode (just press the Power on button when turned off - no bootloader, fastboot or anything like that) and connect it to the computer via USB. The phone memory that opens up on your computer is where you should put it. It really doesn't matter the exact location, as long you can access it later in the TWRP recovery (the Download directory mentioned in the guide is also there). Then you can proceed with Step 10 (or Step 15 if you have already installed the TWRP recovery).

  • That worked; a little confusion that it left was the reference to "The phone memory that opens up on your computer", which I suspect refers to some kind of GUI window. I'm doing this from the linux command line, using adb directly, and that "opens up" in /, which I couldn't put it in as it's a read-only file system. I got "permission denied" when I tried putting it in /data; I settled on /mnt/sdcard, which turns out to be where TWRP initially opened anyway. Commented Jul 20, 2014 at 10:36

Go into twrp mode on your phone and go to install. Then go to where you downloaded the zip file and tap on it. Then just swipe to install and reboot your device.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .