As my wife bought an Android Phone last year, she has been using an 8GB MicroSD card, recently she wanted to increase more storage space due to having more music and photograph files. As such, I bought a new SanDisk 64GB MicroSD card Class10.

I have successfully formatted the 64GB MicroSD card using the phone's Format function and copied all her photos and music files into the card, I can view all the photos and play the mp3 with no problem. I can also successfully install Apps from PlayStore.

The problem comes when I start to move Apps from Internal to SD using the "Move to SD" function, which will prompt me "Couldn't move app. Not enough storage space."

So I thought there might be some residual apps data somewhere in the phone memory, hence, I factory reset the phone, reformat the 64GB MicroSD, and copy all the photos (folder name: Pictures) and mp3 (folder name: Music) back into the MicroSD. Although I have nearly 50GB of free space in the MicroSD, unfortunately, I am getting the same error again.

Details of the phone: Model number: e1901_v77gq2008 Android Version: 4.1.1 Build Number: e1901_v77_gq2008_20130131

Appreciate advice for any kind soul.

  • I'm having the same problem but it only affects large apps (still tiny compared to the available space though). None of the suggested solutions work. Funnily, I just got a 200GB card instead of the 64GB one I had and now I can move ~300MB apps but not a 1.4GB one. Makes no fricking sense. Edit: Nah, just stumbled on a 150MB app that I still can't move. Makes even less sense.
    – Christian
    Commented Nov 7, 2015 at 23:46

6 Answers 6


With some models of phones there is a difference between "internal SD card" and "external SD card", where the former is just a link to the phones internal storage (whyever). The latter is your real SD card.

It might be that you are not able to use your SD card in the way you like due to this limitation. Using a file explorer, can you see a difference between /storage/sdcard0 and /storage/extSDcard (or similar entries)?

What puzzles me most is that you said the problem occurs after a factory reset. So not even the smallest app is movable?


Had same problem: 32GB card works fine, but 64GB card won't move apps even though there's plenty of room.

Solution: connect the phone to the PC and fill the 64GB card with at least 32GB of data (music, video, whatever...). Now when you try to move the apps, the phone will see less than 32GB free and it will work.

App manager in my HTC Sensation 4G apparently freaks out and chokes when it sees more free space available than it was originally programmed to deal with.

  • Worked with Sony Ericsson Xperia Active. Commented Feb 3, 2016 at 16:49
  • can't do that, as when I connect to the "PC" I have access only to the internal storage! :(
    – cregox
    Commented Mar 14, 2017 at 0:23

The problem occured to me when I repeatedly used my phone as an external storage device. After I removed my phone and tried to move an app to the external memory, it says "Couldn't move app, not enough storage space." even I still have plenty of space to use yet, so I waited for about ten minutes and I was able to move the app again.

Removing the sd card and inserting it again, rebooting the phone, reformatting and other similar actions won't speed up the process. Just simply give time for the phone to completely analyze your sd card.

  • There is a background service that analyzes how much storage space on a phone. It's not instant, and I did see I had to wait a few minutes for Free Space to update, even when on a UHS class 10. However I still get errors when moving apps to it so it may be unrelated.
    – Jonathan
    Commented Jun 15, 2019 at 8:42

Am having the same issue, with different SD cards.

When I tried to move the app using AppMgrIII, I got the error "This device doesn't enable users moving apps to the SD card. Usually, it's because of the manufacture removes the function of moving apps to SD from Android...". So apparently, Android could be blocking the copy....whatever target free space is available...


For me, with a Moto G5, I formatted a 16GB microSD card as internal storage, but was getting the "not enough space error". I tried ejecting and re-mounting the card - this apparently solved the problem. (I also tried plugging it in to charge)


If the phone/tablet can only handle 32gb of free space at a time partition your SD card... its just a shot in the dark as many android builds are not capable of seeing two SD cards... and the filesystem you can use are dependent on the kernel, fat filesystems seem to work on most is vfat fat16 and fat32... also ext 2 through 4 are native to Linux which android uses a moded Linux kernel, so you might try those... and in rare cases I've seen android not be able to see two partition of the same fs but could see them if they where different and I've seen the exact opposite too... they had to be the same in order to be recognized....

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .