2

I disabled my default Messaging app some time ago, but now I need to Re-enable it, but when I go to the Disabled tab under Apps, the option to Enable it is greyed out.

Messaging App info page

9

Navigate to Settings > Application Manager > All Then select Reset App Preferences from the menu. Try if this works, it worked for me for some other apps.

  • That would reset all my Disabled Apps and Default Application settings. This is more of a workaround than a solution. But Thanks for you suggestion. I will use it if a proper solution is not available. – John S Perayil Jul 21 '14 at 7:10
1

Lets say if your play store is also showing the same disabled beside the app( for the default app of yours) then you have to reset the application preferences of the other messaging app. In order you understand this first let us understand the concept of Android Preferences

Android preferences come into picture as your device is having more then one application that does the same task and the operating system has to decide which application must be used as a default

Ex:-Let's say you have the default music player and for some issues you have downloaded another music player application from the play store. Due to this there is a conflict arising for what should be the default task to be done.

This is shown by the OS when you click on an .mp3 file. If you choose to open the downloaded mp3 player as default. It will show how to reset your preferences in the future.(application>preferences>De-select the default app for the task )

I suggest you can simply reset your other messaging app preferences for you to enable the default app. As doing the complete reset is troublesome for you to set your preferences again

Else if your Default app is not showing disabled for both the messaging apps then there's a problem with your Android Operating System for which you need to do a Simple Factory Reset.

1

I ran into an similar issue in 4.4.4, moved some app to the system with apps2rom app then deleted it and reinstalled, app became totally invisible, thanks to Xposed module Xprivacy I got a hint that it is 'disabled' and I did re-enabled it with help of Lucky Patcher and all went back to normal.

0

Your problem is very easy mine is very difficulty to solve idid the same thing as u do idesable all messaging apps include google messages app hangouts to trying to send file safe via blue tooth and turn off data connection for 2min myphone was off and unable to work anymore now ihave to buy a new other device that not have google playstore when iturn it on is said keyguardtestactive have stopped Launch3 have stopped hangout out has stopped hangout is desable u your problem is easy just go to setting and reset your phone or downloded avg security or norton security app and wipe of your device it will resette every thing in your phone

  • 1
    you need to format your post and remove spelling errors to make it readable! – AADAndroidEnthusiasts Jun 22 '16 at 5:37

Not the answer you're looking for? Browse other questions tagged or ask your own question.